Failed to detect Apple TV, please quit and re-open Seas0nPass and try again

Hello, im trying to jailbreak an apple tv black, using MAC OS Mavericks.

I Downloaded SeasonPass

When running, it prompts for UI Scripting enable. I click on enable.

The only option available then is IPSW; When trying Boot tethered (even with the icon disable) says: "The AppleTV2,1_5.3_10B809 firmware is untethered and does not require this process!"

After click on IPSW, it prompts then: "No Device Detected. please connect ....". I then connect ONLY the micro USB to the devide. Then click ok.


i get the following error: "No device detected. ailed to detect Apple TV, please quit and re-open Seas0nPass and try again.".

I tried with three different cables, nothing happens. I tried also with the power cord plugged, nothing happens.

Any idea?

Thanks in advance.

I am also interested on this issue. I get the same error and I can not do anything on my ATV2.

Exact same issue for me, I am on Mac (Mavericks).

I'm having the same problem and can't find an answer. Is there anyone who can help us out? 

Same issue for mig :(

Can check the back bottom part of the unit if its a1378 or a14xx?

Mine says Model #A1469


Mine says Model #A1469

[/quote] then you have a 3rd gen....

I have the same problem and my model is 1378.

Same problem here!

1378 (atv2) and OS X Mavericks. Constantly receiving the “no device detected” error message.

I had the jailbreak and fire core running for years. Now I had to restore the atv and running the newest firmware V6.1.2.

Tried different cables, with/without power chord

Any suggestions?

Go to Help > Save Firmware Signatures, then try Create IPSW again. It’ll start to work.

That doesn’t seem to detect it either.

I have the same issue. ATV 5.0.2 with aTV Flash black 2.4. Netflix stopped working a few days ago and one of the threads in support forum suggested reapply latest Seas0nPass. The old version worked fine, but the latest (0.9.5) fails to detect my Apple TV. I have A1378.

Could anyone confirm that v.0.9.5 works with the previously jailbroken ATVs? Any help would be appreciated.

This exactly describes my situation, except I’m on 5.0.1. Two different A1378s, neither show up in Seas0nPass or iTunes. Neither will update or restore. Neither work with Netflix as of last week.

Exactly the same issue here with 5.02 and 2.3, my Apple TVs (I have 2) don’t get detected at all with the latest iTunes or Seasonpass. It does however gets detected with the older Seas0npass (, the one I used the first time, to jailbreak my 2 ATVs… Maybe someone has an idea how to go from there, like resetting to older version or something? Not sure how to do this with Seas0npass. Right clicking? Does anyone has a workaround? Factory reset maybe?

Also no more Netflix: “Netflix is curently unavailable. Please try again later” for about a week or so now…

UPDATE: Never mind, it WORKED when I used another USB cable! Now I will se if updating to the 5.3 will take care of the Netflix problem or not… Updating now.

LAST UPDATE: Yep, Netflix now works after updating from 5.03 to 5.3. Problem sovled. Damn sneaky USB cable!

Had the same problem, also tried 4 different micro USB cables with no luck.
But after I rebooted my mac, and retry, everything works again.

Same problem here. I finally came across a micro USB cable that worked. Apparently not all of them are created equal.

Same problem…
Solution: Just change your USB cable

tested in the version: 6.2.1 / 5.3