failed network connection

after untethered jailbreak on atv2 was working fine before jailbreak

 0.8.5.seasons pass

help - i have submitted my wifi password soooooooooo many times and it says not connected.

Every thing else is connected, just not atv

all i have on my screen is a computer icon, and a FC icon- everything else gone- what went wrong???


THis stongly suggest that the ATV2 does not have a working network connection.   If you can I would try a wired connection to see if that helps.

No the ATV2 will not CONNECT up my WIFI- IT TELLS ME ITS THERE- THEN WONT ACCEPT PASSWORD- password is CORRECT- I’ve checked a thousand times, funnily enough it will connect to a neighbour unsecured network- but then it will not allow me to access my purchased iTunes account, just keeps going back to the enter password screen, just like it did with my wifi network.  Seasons pass must have blocked the password entry or something???   I have reset to factory settings, and it still does same Am i the ONLY ONE WITH THIS PROBLEM.

Happens when there currently isn’t a network connection available.

I haven’t had any problems and have done a couple Apple TV’s as of late. 

Seas0nPass won’t block anything. What is your SSID name? Is it common and you may be trying someone elses? If you can connect to a different unsecured network then it isn’t a problem with the jailbreak or the Apple TV…

No u don’t understand. There is nothing wrong with my wifi. It appears to b the password screen it just keeps going back to the network. Click on network and your back in password.
It also happens i with ITunes log in AND username- (which I can get to if I log into neighbours unsecured no password network.
It must b a glitch in password.screen or apple is one step ahead and once it’s jail broken it wont accept passwords

I have jb’n 3 atv’s with no issues. I would try the jb again, and see if that helps. It doesn’t take very long, and will probably fix any issues you are currently having.

This suggestions something basically wrong!  What type of encryption have your specified at your router for the wifi link?  I wonder if it one that the ATV2 is not happy with.  However your message suggests thatn it DOES work before jailbreaking - is that correct?

Yes there was nothing wrong with my wifi connection or my iTunes account prior to the jailbreak All my other apple devices work still with the same iTunes account and same wifi connection.
I have reset back to factory settings. - and the problem still exists. Now I can connect to neighbors unsecured network - only because I don’t need to put in a password. But still it won’t accept my iTunes password - which I need to enter for home sharing. Please don’t tell me my passwords are incorrect. - they r 100% correct.
As stated the iPad iphone and iMac all work and talk. - the atv2 use to as well p- prior to jailbreak.

Have you tried to hard wire it to your network? Also, I’m sure you have done this, but doesn’t hurt to check; Apple requires at least one upper case and one lower case letter in their passwords. It is easy to forget on the atv2 since you have to go to a different tab at the top to change between them.

I’m afraid you don’t have too many choices.

I would try a wired connection from your router to the ATV2 first. If it doesn’t connect, reset your router then try again (power off both).

If that fails, re-jail breaking next.

If once you have re-jail broken and you still have problems, try changing your SSID and wifi password (I know you will have to re-connect with your other stuff too).

If that fails, I’m out of ideas sorry.


I have exactly the same issue, my atv2 will not connect to wireless, i have tried to re-jailbreak multiple times. it was working fine before jailbreaking, please let me know if you were able to find a solution.

if it’s connecting to a neighbor’s unsecured wifi it means you are putting the wrong key in. you have to find the key because on the apple tv the upper case and lower case alphabets have to be exact