Failed Indexing only on Infuse Pro 7.5.4(4425)

Hello. I’ve been using Infuse Pro for years so much satisfied. I use Infuse Pro 7.x for myself and Infuse 5.x for my kids.

It has been several days Infuse Pro 7.x says it failed indexing my HDD attached directly to the router(SMB protocol) while Infuse Pro 5.x successfully indexes and shows me updated media data everytime I try.

My network is as follows:
TV - ATV(4K 3rd gen) -(1GB ethernet wired)- Router- (usb 3.0) - HDD

I’ve sent two diagnostics from Infuse Pro 7.5.4(4425) with these codes: 7383Y and F861C.

I tried rebooting the ATV and my router seperately and I also tried deleting and re-installing Infuse Pro 7.5.4 which didn’t work for me.

I’m using iCloud syncing and the Trakt sync as well. Can I have a solution for this? Thanks in advance.

What happens if you reattempt another sync by clicking on the “Scan For Changes” button on the library settings screen?

You may have to try it a couple of times while watching the status messages under the video counts on the left side.

Oh, I forgot mentioning I tried that several times with no luck. :sweat_smile: Clicking that button is what I had been doing usually to get my library up-to-date back when there was no problem with indexing.

@NC_Bullseye Can I have another suggestion to try? Still no luck here :sob:

So since a few day ago you’re not getting any connection to the share or it’s connecting and you can play videos but it’s just not updating?

It started about a few weeks ago. No video playing or updating so far on Infuse Pro 7.5.4 while Infuse Pro 5.x works without any problem.

Are you using the router as a server? It sounds like the settings in the router may have changed. You may want to check on the router to make sure the ATV still has permissions to read and the name and password are still the same.

Thank you for the advice. In fact I’ve not changed the router settings in years(and I’m the only admin). That said, I’ll have a look anyway and will get back with the result!

Can you identify any differences in which the devices on which you have Infuse 5 installed (for your kids) are connected to your portable hard drive, compared to the way the Infuse 7 devices are connected — specifically in the Infuse settings that set up the share?

Which devices are running Infuse 5 and have you attempted using one of them to test Infuse 7 from a different device (to rule out issues specific to your primary Apple TV)?

OR, do you have both Infuse 7 and Infuse 5 installed concurrently on the same device, connecting to the same hard drive?

And finally, have you tried updating to Infuse 7.5.5?

Thank you @FLskydiver!

Yes, Infuse 7 and 5 are both installed on the same ATV:
ATV(4K 3rd gen) - (wired ethernet)- Router- (usb 3.0) - HDD

It was 7.5.4 until yesterday but yes, I see it’s been updated to 7.5.5(4434).

I checked every admin page for the router’s settings but I couln’t find any changes that could’ve lead to current status.

BUT, I happened to solve the problem trying a new approach that I still don’t understand why only this worked:

  1. I selected “Forget this Share” in “NETWORK > Shares > SAVED SHARES > [my router] (SMB)”
  2. Then my router’s name appeared in “AVAILABLE SHARES” again and I selected it again as SMB connection.
  3. As I haven’t set a password for my router’s network share, I left Username and Password blank as it had been like that for years as well as MAC address section.
  4. I tried to save the share setting and Infuse gave me an error message that it couldn’t reach my share(forgot the exact message).
  5. Then I went back to my router’s settings page to try(hardly believing this would work) set a password for read/write access, and entered it to the SHARES setting screen of Infuse 7.
  6. I also entered the MAC address and the Workgroup name for my router as well, which again were never done before.
  7. I saved the share setting again and Infuse 7 accepted that magically.

I could load up my folders to the library and now Infuse 7 is indexing my library!

Again, I have no memory of either having my router’s HDD set with a password for network share or entering my router’s MAC address in Infuse 7’s settings page.

As my Mac’s Infuse also has been saying the Indexing failed for my router’s HDD(SMB) from the same day when ATV’s Infuse 7 failed reaching the SMB share, I’m going to do the same thing for the Mac version.

Oh, then and I set the same Username and Password for my Infuse 5’s Shares setting now the network folder is set to require passwords and the connection was succesful without a problem.

Happy to enjoy Infuse 7 again for now :smiley: but still curious why things have changed or what I have missed. :eyes:

1 Like

You’re very welcome. Glad you got it sorted!

It sounds like something updated in your router to provide better security, and your Infuse 7 installations were denied access (perhaps after they updated and needed to reestablish their links).

Infuse 5 hasn’t been updated in a long time so possibly continued accessing content because the router had already been granted access and Infuse 5’s lack of updates never broke the connection … or perhaps Infuse 5 lacked the ability to communicate on the newer protocols used by the router to maintain secure connections.

Just hypothesizing, don’t really know.

1 Like


I’m having the same issue. Works on all devices except for Apple TV.

Strong Ethernet connection except I add a Plex share.

Any clues as to why it won’t pull any content from a remote Plex server?

No changes have been made server side. It literally just stopped working 2 weeks ago

Are you sure? Do you have control of the server?

First troubleshooting steps would be verifying your settings per instructions here; removing the Plex share from Infuse as explained by the user above and reconnecting to it; and then possibly deleting the Infuse app and reinstalling it if updating to current version has already occurred.

Infuse 7 says ‘Indexing failed’ again after one day. It’s indexing my Mac drive(shared via SMB) successfully but it fails for the router’s SMB drive. :cold_sweat:

Yea - it’s a synology dsm 7 setup running Plex. I’ve been using infuse for years, every major pro version purchased and Plex premium.

Yesterday I checked advanced permissions, checked port forwarding settings on router.

Odd thing is infuse works perfectly on Mac OS, iOS, ipad os, it will only add something if I play it inside Plex.

At this point I have no idea what to do. Sucks because Plex doesn’t really handle 4K too well in Apple TVs.

Wish you good luck with your issue, please update if you find a fix.


Check the port forwarding rules. It’s not secure to keep ports open all the time for SMB but I think there’s a way around it - maybe setting up a proxy server?

Getting and Index failed (after an initial bit of Fetching has happened) as well when connecting to my Emby server. InfuseSync installed as well. Something changed.

Well, that’s a bummer.

Your external hardrive, connected to the router, is it turning on when you begin indexing from Infuse?

Maybe the router isn’t waking it up when Infuse tries to connect to it?