Factory & restore with USB as primary - aTVflash won't work

Yes, I know I should have removed the USB as primary drive - I was running pre v3.6 & couldn’t find command line type instructions on the wiki
I tried upgrading to v3.6 to see if I could the menu driven method for uninstlling primary USB, but not available.

  1. So I did a factory restore,
  2. upgraded to Apples v3.0,
  3. down loaded (windows 7) the aTVflash v4.0 to the same flash drive I’ve always used (I did not separately reformat the flash drive)
  4. installed on aTV - it installed ok, but the aTV restarts into diagnostic mode

I did this process a couple times with the primary USB both connected and not connected.

The bare aTV (v4.0 w/o aTV flash) works fine.
ps - I love my aTV & really like the aTV flash product

You should reformat the usb disk-on-key before flashing it. Otherwise it does not work.
So do everything all over again. This time reformat the usb thingy.

Good luck

Thanks!! It worked.
I was reading other installation posts & thought that I should reformat the flash drive.
Thanks a gain for the quick response!