EyeTV

I have just installed EyeTV 3.0.1 on my atv(1) and it works! :slight_smile:

However there is a small issue and everytime I launch the app it says it needs to install an item and asks for the frontrow password.  Having put this in the app works BUT I get a message saying that it failed to install sometghing to do with  wake from sleep.  There appears to be no option in eyetv to activate / or disactivate wake from sleep and thus make the element irrelevent.  At the moment I have to keep a keyboard attached just to put in the password each time, which is not exactly wife-friendly!

 

How do I get round this?.. pls dont ask me to upgrade my wife!

 

To install eyetv I did this:

  1. Run smart updater

  2. Activate keyborad magic

  3. On my mac mount the eyetv disk image

  4. SSH the app directly from the image to  /frontrow/applications on my ATV

  5. Run the app from nitotv/appclications, using a usb keyboard & mouse to input pswd, sn etc as necessary

 

Any ideas?

 

Thanks

jw

 

You can read this thread:

It is very important that before running a fresh copy of EyeTv (not the one you already have on ATV) you type the command:

sudo mount -uw /

This will make the root partition writable allowing EyeTV to install some files the first time it runs.

After the first launch, quit the application the way you would do on your mac (mouse -> file menu -> quit, not just hitting the menu button on remote).

This worked for me.

mu_ri, thanks for the response - i was about to give up hope.

 

  1. I havent used terminal commands on my ATV but I presume its a case of opening Terminal on my mac, then

ssh frontrow@AppleTV.local

(psswd) frontrow

sudo mount -uw

Correct?

 

  1. Will this process work now i have already tried to run EyeTV?  Or would I be better trying to delete all evidence of EyeTV on the ATV (app, plist, application support etc) and starting again

Just remember the last slash!

You will be asked again for password, then you can run a FRESH copy of EyeTV (delete the one you already have on ATV).

2 It shouldn’t be necessary, at least it wasn’t for me.

yes this solved that problem (many thanks!) and now I almost have a great media centre.

the remaining issue is one of control…  is there any way to make eyetv fully controllable via the ATV remote? At the moment it responds partially to the remote and I can freeze (not pause) live TV, (pause button) raise/lower volume (up/down) and change channels (left/right).  Is there any way to get to be able to control more, without resorting to a mouse?

I am using a Terratec cinergy XS hybrid usb stick

thanks

No way :slight_smile: too few keys on that remote!

You’d better use the Terratec original one.

I have bought a Logitech remote from amazon, very cheap and fully compatible with Terratec decoders.

Choose the model with usb, you can program the remote for EyeTv, AppleTv and also XBMC!