Extras Not Installing - Installation Failed!

Just installed Seasonpass to jailbreak and then the latest version of ATV Flash black.  When trying to install the media player, I get Installation Failed!  Numerous retries are met with the same error.

When I click View Log I get:


E: Broken packages


Building dependency tree

Reading state information…

Some packages could not be installed.  This may mean that yolu have requested an impossible situation or if you are using the unstable distribution that some required packages ahve not yet been created or been moved out of Incoming.

The following pacages have unmet dependencies:

come.firecore.media: Depends: com.firecore.libafpclient (>= 1.3-50) but it is not going to be installed.

Reading packages list…

Building dependency tree…

Reading state information…

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded


Same problem with XBMC - I haven’t bothered with anything else.  Suggestions?  Thanks!


also getting the exact same problem… only nitoTV installed

Same problem…


Same issue here trying to install Media Player. Couch Surfer installed fine. I think it has to do with the repositories being slammed today with all the people jailbreaking.

nitoTV installs but when you try to install the libafpclient from the sources, it also fails. 

This is with aTV Flash 1.5.1. Thanks!


Can you guys please get on the ball with this stuff?

Now I can’t watch any of my media from my library.

This is unacceptable.

Got it fixed following the directions on the previous post:

Run these three commands from SSH prompt:

killall -9 apt-get aptitude rm -f /var/lib/apt/lists/lock apt-get -y update (if it times out or takes a *really* long time, press CTRL+C and run the command again)

It worked for me! 

Thanks for the guy with the solution and the for the guy who refered to that solution!

You both saved my night.

Yes, that worked for me too!!

Thanks a lot!

My fix:
1- Played song through AirPlay.
2. Reinstalled aTV Flash.
3. Unplugged power for 10 minutes.
4. Plugged power back in.

Was able to install Extras through Maintenance. Total time 12 minutes! Plus Without SSH fix!

how about a better explanation. what the heck is SSH prompt? how do you do it. you know, we are not all programmers!


SSH is just a way to remotely access the command line. If you are on Mac you can access SSH from the Terminal. On Windows I use a client called PuTTY. You will need to know the IP address of your ATV2. Once SSH connects, you can log in as user ‘root’ and the default password is ‘alpine’.

Look around you should be able to find some tutorials on google and youtube if you need additional guidance.