External USB Drive shows in Sapphire but not NitoTV

I apologize in advance if the answer to my question turns out to be embarrassingly simplistic, but I have combed through the forum reading various posts about external hard drives not mounting properly or showing up under NitoTV etc…and I have yet to find anything that will solve me specific problem.

 

What I would like to do is use my external (already HFS+ pre-formatted) Iomega 1TB eGo Firewire/USB portable hard drive as secondary storage unit (connected via USB) connected to my AppleTV.

 

Latest version (4.2.1) was loaded this past weekend, everything installed, updates checked (none found), smart installer run (and date confirmed on menu)…but when the portable hard drive is connected via USB nothing shows up under NitoTV>Files.

 

Based on posts already read, I have tried connecting the hard drive while the ATV is on (plugged in)…tried when it was unplugged (and then plugged back in)…all to no effect. I have checked to ensure the USB cord is plugged in properly…I have even used different USB cords.

 

I know there is much talk about formatting of the drive, but (as I already mentioned) this came pre-formatted as HFS+…so I can’t see that being the issue either.

 

What is strange is that Sapphire obviously detected the external hard drive, as I was able to fetch movie/Tv show data and play from Sapphire (which I found choppy BTW). So why not NitoTV? The fact the drive is detected by Sapphire and not NitoTV seems to suggest the USB cord is working, and plugged in properly.

 

Anyone have any suggestions (other than simply resign myself to watching through Sapphire)?

Out of curiosity, what is the current name of your external drive?

I t has been named "Supersized"

I have the same problem.... any solution?

You may try this.

  1. Power off the AppleTV.
  2. Disconnect the external drive.
  3. Power on the AppleTV.
  4. Connect the drive after the main menu appears.