External SRT works in all other players EXCEPT Infuse!

2023 Mac mini M2 Pro, Ventura 13.2.1 . Infuse 7.4.10. Video files on a local network computer (Mac Pro in my garage).

I’m not able to get external .SRT files to show-up in the subtitles menu on certain movies. These SAME EXACT .SRT’s work in VLC, Movist Pro, Optimus Player, and IINA video players - so it’s definitely just Infuse (the ONE player I want to actually use!).

When I drag the .SRT into Infuse, it even says “new subtitles added”… so I know they were added… just not viewable to click on. Also, sidenote: if the .SRT is named the same as the movie file, why do external .SRT’s NOT AUTO-LOAD when I open the movie? --like every. other. player does?

I only have maybe 20-25x 4K HDR rips I’m testing with (just got a new HDR-compatible 2023 Mac mini)… and so far 2 or 3 movies have this issue (many are just fine… after manually adding them), so that’s a pretty bad percentage (and I haven’t even tested them all yet!).

What can I try to fix this? I HAVE to use external subs, because you can’t change the HUGE font size Infuse seems to default to when the subs are internally part of the .MKV or whatever container video file (I’m open to any fix for that as well - it’s VERY annoying… especially then they’re coded to NOT be on the bottom only, but are all over the screen).

1 Like

hey, I am also a user incurring in problems with .srt subtitles, I opened a thread here

I am just curious to know if this is happening to you on your local network, or when accessing your library remotely. Because .srt files work for me on my local network, but not over the internet.

1 Like

Yeah, I like my subs tiny and unobtrusive, too.

Text based subs (like .srt) can easily be edited by player software (and thus you’ll get display options in Infuse and elsewhere to use different fonts and fonts sizes and precise vertical/horizontal positioning, etc.).

Other subtitles are image based; and as transparent images meant to be shown on top of the content in a specific way there isn’t a lot that can be done to edit their presentation; apart from people similarly annoyed by them using OCR tech to convert the image based subtitles to editable text (which is why some hastily converted .srt subtitle tracks you might have encountered include those weird OCR-generated typos).

Have you tried including your external .srt files inside the container using something like MKVToolNix? While ideally you’d definitely want Infuse to pick them up automagically, I wonder if including them in the container can help in the meantime, while your issue is looked into.

Out of curiosity, do you keep the subs in the same folder as the video files, or in a folder named “subs” that’s in the same folder as the video file? I do the former, and have never had issues — but I haven’t tried accessing my content from outside my home, which is the situation in which the user posting above me encounters their version of the issue.

@brotello I’m solely local (files are on an ancient 2009 Mac Pro in my garage with like 30TB hooked up to it) - so I don’t think your remote issue is the same as mine (sorry you have that issue though, that certainly stinks).

@FLskydiver , the problem that the embedded subs can NOT have their font size changed, and/or have everything on the bottom of the screen is EXACTLY why I’m using external .SRT subs!!!

And no, I have probably 3,000+ videos, it’s just not worth that massive effort to to manually add my .SRT files inside each movie container (plus I’m pretty sure Infuse disables the text size option when they’re internal - ONLY when they’re external .SRT files does that font size option come up in the settings) - so that wouldn’t be a working solution.

.SRT files are in the SAME folder as the movie.

Also wanted to mention that two of these issues are sporadic with only SOME movies. Some movies seem to pickup the accompaning (named the same) .SRT file automatically (I think, not positive). Others do NOT pick that same-name .SRT file up and I have to manually drag it to the Infuse window. The other BIGGER issue is that even with manually dragging the .SRT file into Infuse, SOMETIMES (only sometimes, not all the time) those external .SRT files will NOT come up in Infuse’s subtitle window! This seems to be movie-specific (meaning that the same problem movies will NEVER let me manually add a .SRT – not that it sometimes works, and sometimes doesn’t - it never works… even trying multiple different .SRT files – which again, work everywhere else).

This is really just a wild shot in the dark but instead of typing the movie name on the SRT file have you tried doing a copy of the movie file name and then pasting it on the srt file? I’ve seen cases where a hidden character in the movie name could cause problems.

1 Like

When I add .srt files into a movie container (which I’ll do when I have to edit the container in other ways … for example when adding or removing various audio tracks, or when splitting or combining multiple television episodes to match up with TMDB’s data), all the abilities to adjust the .srt files in Infuse remain the same. I suspect the tracks you can’t change the display settings of aren’t text-based tracks. MediaInfo can tell one way or the other.

If you isolate why some titles seem to work and others don’t, that might help figure out what’s going on. Maybe use MediaInfo to look for distinct commonalities in those that work and those that don’t.

True. Another might be how different subtitle tracks are distinguished:

For example, if my movie file is “Dune (2021) 4K HDR.mkv” and I have standard and hearing-impaired subtitle tracks with it, I’ll name them “Dune (2021) 4K HDR.English.srt” and “Dune (2021) 4K HDR.SDH.srt” — this convention has worked fine for the tens of thousands of subtitle tracks in my collection. But if one got accidentally named “Dune (2021) 4K HDR English.srt” or “Dune (2021) 4K HDR-English.srt” those might not be picked up.

@NC_Bullseye – My process is simple – I’m not like manually re-typing a 100+ character movie name… ALWAYS hit “enter” on the file name so I can Command+C/copy it verbatim, then paste it into the .SRT. They’re EXACT duplicates of each other’s names (just one is named .SRT and the other named MKV, MP4, or AVI… whatever video format it is).

@FLskydiver – I’ve been using VLC media player for probably 10+ years. Have a library of 3,000+ videos - every. single. one. has an accompanying .SRT file. They ALL work perfect. I can change the font size at will. Never, ever, a single problem for thousands of video files.

Now that I have a HDR-compatible computer I’m testing HDR movies out. I’m using the same exact everything I was using before, the same exact process. Those same exact .SRT’s work PERFECT in the other (competing) HDR-compatible Mac video players like Movist Pro, Optimus, and IINA…

Despite those players ALL having some major shortcomings (which is why I like Infuse a LOT more, and why I’m posting here!!!), .SRT compatibility is NOT a problem on them. They all work perfectly (some lacking in menu options to customize sub settings, but the subs are still technically working as they should). It’s ONLY Infuse where I have issues with these SAME EXACT subtitles…

So therefore in my eyes the problem lies with Infuse specifically. Hope the above doesn’t come across as harsh… just saying that if every other player in existence works, and Infuse doesn’t, it’s really just a problem with Infuse (and NOT a problem with how I’m doing things, which files I’m using, how I’m renaming things, etc. etc.), thus me posting on their forum to hopefully have the developers try to see what’s up!!!

Okay, that takes care of missing a hidden character in the video name but that doesn’t eliminate the possibility of a hidden character in both causing problems. Just as a test since you have specific videos that exhibit this problem, try typing the name for both on one and that will eliminate the possibility of any hidden characters on either.

1 Like

I hear you. But you also say the problem is intermittent — that only some times do SRT files not get recognized with their matching movies. So I’m suggesting you try to figure out why that might be. What is unique about all the ones that work, and/or all the ones that don’t?

There are programs you can use to automate the process of cleaning up those outrageously long filenames, if you were so inspired. Might be worth giving it a shot.

How are you browsing and playing these files? Are you using Infuse to browse the library, or are you just dragging and dropping files into Infuse from Finder?

Are you using something like SMB to stream from the Mac, or something else like UPnP/DLNA?

If you use the Infuse > Add Files menu to browse the source, do you see the SRT files listed there (these will appear below the list of video files).

@NC_Bullseye As I’m going through these videos (i.e. watch them nighttime) I’ll give that a whirl. Thanks.

@james I’ve been dragging the movies to the Infuse icon, or if it’s already open directly into the window. For the file transfer method - I don’t really know. When I’m signed into both computers (the 2009 Mac Pro I use as a file server, and the 2023 Mac mini), the other computer shows up automatically in my network locations in finder - I just click on it and I can access all the files from the multiple drives (simple File Sharing was setup beforehand for each volume through System Preferences > Sharing).

So right now, like I said, I haven’t even had time to go through all the movies. I’ll try to take notes and post here again when I find the next problematic one and go from there.

Also wanted to ask - does Infuse automatically copy an external .SRT file to a hidden location somewhere? With that first movie I caught this issue on, I deleted the .SRT file (to try another). Emptied trash and everything… and it’s STILL showing up in the Subtitles as an option to select AND seems to work… can’t figure out that one…

Quite possibly become part of on-device metadata cache; as I believe subtitles download through the app are preserved for future use … though I expect they’d probably get wiped out if you delete your local metadata cache (unless they’re also backed up to iCloud?).

@FLskydiver @NC_Bullseye …wouldn’t you know it… I posted too fast. RIGHT after posting I tried to watch the good old Goonies movie in 4K… and it will NOT load the .SRT file.

Renamed the file of both to simply “goonies” (typed by hand, no hidden/special characters), and tried it again, does NOT show up in the Subtitles menu. Loaded it up in VLC and it immediately not only showed up, but uses that external .SRT from the get-go.

Here’s in Infuse, originally opening the movie with the .SRT named the EXACT same thing - .SRT does NOT show up:

So I then manually drag the .SRT file into the movie, and it tells me it’s added it:

I go back into the menu again, and it’s the same as that first pic I posted - NO option to select the external .SRT. I even manually go into the Advanced Settings and it’s not listed there either:

Sidenote: I (kinda) found where the library of manually added .SRT’s are in Infuse. Found this menu when I clicked on “Imported”. You can see past ones I’ve tried (many of which I had issues with), and the new “goonies.srt” I just added… but can’t access for whatever reason:

And for our baseline, here’s the good old VLC drop-down which clearly shows the existing baked-in/internal “English (English SDH)” subs, which is the only one which Infuse sees… then ALL the way on the bottom is the imported EXTERNAL “goonies” .SRT file which is working properly (and also works properly in every other player I’ve tried, except Infuse):

Playing videos this way won’t usually pull in the external subtitles, unfortunately.

Instead, if you set up a SMB share for the Mac server in Infuse and browse through the folder/library options within the app you will be able to utilize the external subtitles you have.

@james So the thing is, from what I said in my original post - they DO pull that way (by dragging them into the Infuse window, or the Infuse Icon, or File > Open), but only sometimes… The Goonies one last night was one of them that didn’t work – but seems like if I manually go into that 'imported" menu I CAN then choose the External .SRT.

Can this please be put on the list for the developer(s) to fix this? It’s literally the complete opposite of how literally everything else works, on both PC, Mac (heck, even Linux probably lol) for the last 20+ years… this makes it super un-intuitive… and the last thing you want is turning off potential customers.

On ALL those other programs/platforms I literally open the movie and it’s all set with the external SRT…

On Infuse I HAVE to:

  • Open the movie in Infuse >
  • then manually drag in the external SRT >
  • go to Settings Cog >
  • Advanced Options >
  • Scroll all the way down to Subtitle options >
  • Scroll again (now in the subtitles list itself) all the way down to the bottom of that list >
  • Click on “Imported” [subtitles] >
  • then AGAIN (now the 3rd time lol) scroll past all the other imported subtitles >
  • Keep scrolling because EVERY. SINGLE. imported subtitle, of EVERY movie is listed here >
  • Oops, scroll back up a 2nd, 3rd, back down maybe, back up a 4th time because they’re NOT in alphabetical order so you prob missed it (see screenshot above of this :wink: >
  • Then select it and it’ll actually work…

(the above is means to be humorous… but it really is literally, like 10 extra steps for such a simple thing as subtitles!!!)

The Library option… thank you for the suggestion, but to be honest I really don’t need, or want to have to mirror and maintain another library I already have working in my house (already have Plex, mirrored to like 3x different smart TV’s, my decktop computer, phone, and multiple Laptops). Don’t even think Infuse is available on all TV’s or what (just tried it on my brand new Google TV and it said not available… haven’t tried the TCL Roku TV’s in my house yet… but that’s besides the point). Plus, sorry to be blatant, but the organization and way you browse just isn’t nearly as nice as Plex… nowhere near as fully featured in so many, many ways.

Infuse supports Plex. It can use the same Plex library as all your other non-Apple devices.

@FLskydiver , I did see that option, but that’s not a real solution though, I can’t use Infuse like I can use Plex. Navigation is clunky for starters (no bar ALWAYS on the left side to quickly go back to my numerous different separated-out libraries). Can’t start/stop a movie that was playing on my Google TV (unless I’m missing where that feature is in Infuse), then start watching it on my desktop. Can’t use the same type of advanced sorting mechanisms I use constantly to pick out what I want in a certain genre, in a certain year, etc. etc. – hell, I use Plex’s boolean logic “is” and “is not” type search stuff all the time…

Also have to say it (overall man, not talking just about you - I appreciate EVERY ONES help with this issue!): workarounds are all great and dandy… but the root problem is that Infuse does NOT work like everything else does, and/or/plus making you jump through hoops (i.e. adding different libraries just to get a feature that works EVERYWHERE else just by double clicking a movie file! – OR having to do the ~10-steps I outlined above to do this).

Understood. But I don’t write code for Firecore or work for them in any other capacity, so the most most of us can offer you are “workarounds”. I mentioned Infuse supporting Plex because your post didn’t make it clear you knew that.

I read from many Plex users here that they love the features available in Plex but vastly prefer Infuse for it’s unmatched ability to play back everything you throw at it. I don’t follow exactly how/why you are using Infuse (as I don’t have a Mac) but it appears James does understand, and is aware of your request.

Blue skies…

1 Like

I actually just found out that Plex standalone for Mac does NOT do HDR believe it or not! (only their browser version, which I can’t use as I ALWAYS have multiple tabs open, and are doing work in the HDR compatible browsers I use… HAVE to have a standlone HDR-compatible player, thus trying out Infuse). And I also hope @james sees how the subs are an issue when people use Infuse like any other program.