External Drive not showing & a re-install problem

I’m still having troubles getting my apple tv to see the external drive that I have connected. ( http://forum.atvflash.com/viewtopic.php?f=12&t=3234#p13618 ). I am in the process of reformatting my drive (again), and re-installing the ATV software, plugin’s etc. But nothing seems to be working. After I installed the smart installer, it said it was successful- but the drive was not showing. I tried restarting, powering down, multiple times, and I plugged in the drive at different stages, and nothing is working. This last time when I reinstalled ATV I got an error message at the end of the Smart Installer (See attached). Nothing seems to be working- any ideas? I’ll be able to try again after I have tried the reformatting and copying the content to my drive for the 2nd time …

I have the latest version of ATV, AppleTV software, and an external 2TB Western Digital drive that is USB …

I am having the exact same problem. I have two apple tvs. Did this to one of them a little over a week ago with 4.1.2. No problems. Works fine.

4.1.3 comes out. I can not get it to read any hard drive I connect no matter what brand or formatting. I have double checked that everything is updated and installed. Checked each specific file manually. No dice.

AND after it tries to find a Hard drive and can’t find anything. The system freezes and then reboots it self.

I think the problem is with the updated system? Or maybe Nitotv’s update? Worse when I try to reinstall 4.1.2 onto my flash drive, the installer no longer works saying we have to used the latest system! Also I have tried factory resetting over 4 times now and reinstalling everything.

Any help would be appreciated out there but thought I would add on to my problems since they are the same.

i have the EXACT same problem. Must be that Smart Installer is not compatible with latest Apple TV update.

So here is the latest update- I was finally able to get everything to install correctly (for the 2nd time- but it took 4 attempts). However, even though the ATVFlash installer says everything is happy, I cannot access the external drive- either through Nito or any other app. This is a little frustrating for me, as that is the one feature that I got the app (and paid the life time membership) for- and if this one feature doesn’t work, then it is useless to me, as I do not need / want the other options. (Although they are really cool features.)

Any ideas / thoughts / solutions?

I believe the download issues should now be resolved. Also, you will want to install both the Maintenance and nitoTV updates that are now available via Maintenance --> Manage Plugins.

That did not work either- the external USB drive will not be recognized no matter what I do- is there anything else that can be done?

  • I have reinstalled the software for the 3rd time.
  • I was able to get all of the updates / plug ins to install correctly.
  • I have tried my Western Digital 2TB USB drive (Plugged in to external power.).
  • I have tried my Seagatel 1TB USB drive (Plugged in to external power.).
  • Both drives are Mac Formatted (Journaled)- And I even formatted them two separate times.
  • The WD drive has 1TB full of content, the Seagate has 300GB of content.
  • I have tried restarting the ATV.
  • I have tried plugging it in after the ATV has started.
  • I have done a rain dance in order to please the ATV gods … :wink:

But not matter what I do, NitoTV does not see an external USB drive, and further more when I go into maintenance to change the iTunes storage to external it says that there are no external drives connected. From what I can tell, the problem does not seem to be on my end, as I have tried all of the available options … this is getting very frustrating for me … please help …

Are you using any type of USB hub, or are the drives being connected directly to the AppleTV?

No hub is being used- the drives are connected straight to the ATV. I know the USB port works, as that is how the ATVFLash is installed. But the drives do not show up …

I have tried since and it is still nit working. Even checked with using cyber duck to make sure everything was downloaded and loading correctly. Nothing.

SO are there any answers / solutions, or am I out of luck???

There was an update for nitoTV released on 6/15 to deal with some USB drive issues. Please install this update through the Maintenance --> Manage Plugins menu and re-run the Smart Installer. This should resolve any issues you are having.

YEAH! It works- thank you very much! Everything is working as expected now. :slight_smile:

I’ve update the NitoTV and re-ran the smart installer…I still cannot see my attached drive. HELP!!!

Do you know the size and format of your drive?

320 G External Hard Drive formatted Mac. I used to be able to see it before but not now anymore. I’ve tried everything. Factory reinstalled at least 3 times.

I’ve also tried removing nitoTV and then reinstalling - still no USB external drive. HELP!!!

Are you using a USB hub or is the drive being connected directly?

No hub, direct connect.

Some drives prefer to be connected after the AppleTV is powered on. You may try the following.

  1. Power off AppleTV.
  2. Power off external drive (if it has a power switch.
  3. Disconnect external drive.
  4. Power on AppleTV.
  5. Connect external drive after AppleTV main menu appears.

I have the same problem without any answer from ATV flash support:

I cannot connect to a external HD or my Time Capsule, using nitro TV.

The Time Capsule and my Mac Book are show in the Network setting, under nitro TV.

After I follow the video to connect my Time Capsule with the first step:

  • Add Manual Share Point; after the completed all the steps that is the message:

Network Mount Filed!
mount_smbfs: tree connect phase failed: syserr= No such file or directory
mount_smbfs: tree connect phase failed: sysserr= No suchfile or directory

Second issue the External HD:

After I plugged my external HD I cannot see the external HD in nitroTV files