Exploit injection failed

Okay, I have a black Apple TV and I've tried to jailbreak it and do a tethered boot several times tonight. The jailbreak with Seas0nPass went okay. I then went on to the tethered boot. I got it to connect and I got the aTV to enter DFU mode. After about a minute, I get the message "Exploit injection failed". The whole process just stops there. I tried repeating the whole process from the start - 1. jailbreaking (again), then 2. tethered boot. Now, Seas0nPass just gangs there in "waiting for device to enter DFU mode" phase even if I disconnect the aTV, quit Sea0nPass and start all over.

I tried this whole process back in December and failed. I would love to get this to finally work without banging my head against the wall all night again. Any help would be appreciated. Thanks.


Oh, and "Yes", I did hold down the Menu and Play/Pause buttons down for 7 seconds.

Okay, I let the aTV sit unplugged (neither power cord, nor USB) for about 20 minutes. I then started the process ALL OVER AGAIN. It kind of worked. The last thing I did was wait for the software to tell me it was successfult, then I swapped out the microUSB for the HDMI cable.

I then unplugged the aTV and took it downstairs so I could connect it to the HDTV and stereo. Now all I get is a pretty silver apple on my TV screen and nothing else. It dawned on me that perhaps I'm not suppossed to unplug the aTV after the tethered booth. But, this would be a huge flaw in the jailbreak process because most of us don't have our computers sitting next to our televisions, so you'd have to unplug the aTV and transport it to the room in which your TV resides.

Anyway, giving up. Hopefully by tomorrow morning the aTV Fairy reactivates my aTV and makes this entire nightmare go away.