Experience with the Green Apple

Sorry I couldn't post this in the original thread, the forum software kept saying couldn't find the URL.

 

[quote="Catastrophe"]

Worked like a charm for me, i did a restore in Itunes before atempting.

During the jailbreak it says to plug in both your usb cable and power, make sure to unplug the power cord again after aprox 3 seconds. It isnt clear in the instrutions that you need to unplug it agian.

 

1.  Plug in your ATV 2 with the usb, and run GP.

2. Plug in the powercord for 3 sec, and unplug.

3. Hold down menu and play / pause for 7 seconds.

4. When its in DFU, click "Jailbreak"

5. Once its completed, let it stay plugged in for atleast 40 seconds before removing.

6. The first time you start up your ATV 2 after the jailbreak a new menu called Greenp0ison will show up, from here you can install various apps including XBMC.

Hope this helps, Good luck.

:edit:

Windows 7, x64 bit.

[/quote]

 

This was correct but still a little confusing for me.

Recommendation -> (tightly timed choreographed movement and things to to, so read all the directions below first and act it out before beginning)

The [key] to the procedure is to get it info DFU mode before clicking the Jailbreak button in the greenpoison program.

I could not get it into DFU following the greenpoison onscreen directions.

 

My setup, Mac mini running 10.5.8 Leopard

Griffin micro-usb cable bought at the Apple store. [ USB Mini-cable Kit - Made for iPod, works with iPhone ]

Apple TV software version 4.1.1

 

1. do not plug in appletv2 power

2. do not plug in appletv2 micro-usb

3. download the greenpoison zip file to the MacOSX desktop

4. dbl click the greenpoison zip file to unzip it automatically creates a folder with the greenpoison executable and a readme text file

5. plug in micro-usb cable to the appletv2 and to the computer where greenpoison will be run

6. plug in appletv2 power cord "briefly, 3 seconds (this is Very difficult), it is hard to pull it back out without pulling out the micro-usb cord, the appletv2 micro-usb must remain connected to the computer" you must quickly move to the next step while the white light on the front of the appletv2 is still blinking.

NOTE: That is [correct], your jailbreaking the appletv2 (while it is disconnected from its power source)(this can seem unintuitive to some, but the appletv2 is getting its power from the computer doing the jailbreaking through the micro-usb cable)

7. quickly grab the appletv2 silver remote and press both the small circle buttons (menu) and (play/pause) at the same time and aim it at the front of the appletv2, count 7 seconds and release, you must quickly move to the next step - its in DFU mode but won't stay in this mode for long

8. dbl click the greenpoison executable (no time to read) and press the [ Jailbreak ] button at the bottom of the window - and stand back and watch

9. a blue barberpole will indicate its updating the appletv2, if your successful, if not it will change the button to [ Try Again? ]

A. after it finishes the blue barberpole button will say [ Complete ] - do not touch anything for 40 seconds, its still updating, appletv2 takes more time than other devices to complete the jailbreak - look at your watch, look at a clock, or look at the time on your phone, wait 40 seconds - a watched appletv2 does not boil, there is no egg timer to go "bing!" that indicates its finished, you will get no feedback at all

B. click the [ Complete ] button, greenpoison will go away

C. for good measure, I waited another 40 seconds after green poison went away to disconnect my appletv2 from the comptuer doing the jailbreaking

D. plug appletv2 back into your network (if you use ethernet), hdmi and power

 

Waiting for network time...

(wait 2 minutes, your boot may be quicker, but it will be longer than your use to booting)

 

The menu will look familar but the line up will now say

[Movies][TVShows][greenpois0n][Internet][Computers].....[Settings]

 

Under the [greenpois0n] menu

...

[Inject Software] -> if selected -> Cydia Payload, Cydia payload including, SSH Version 4.20, Architect Chronic-Dev Team

[About] -> if selected -> About greenpois0n, greenpois0n rc6

 

Downloading Cydia Payload<- selected

Dowloading Package: appletv.tgz

Installation Successfull!

Press Menu to Reboot

 

Pressing menu buttom on silver appletv2 remote

NOTE: This reboot, not from a cold start seems much more normal in speed, suspect the "long" reboots reported are a result of Apple Housekeeping apps that are normally there and we just never really notice, because at 4 watts who unplugs their AppleTV2 ?

 

The menu will look familar but the line up will now say

[Movies][TVShows][nitoTV][Internet][Computers]..[Settings]

 

Under [nitoTV]

[Install Software][openssh][Overflow][Slidshow][XBMC-ATV2][VNC for atv][BTstack][..][Search for Packages][Update All]

[Weather][Weather Manager][Amsterdam][Philadelphia][Phoenix][Vienna][Add Weather Location]

[RSS Feeds] [Digg][Engadget][ESPN][Gagetoid][TUAW][Add RSS Location]

[Settings] [Update nitTV][AppleTV Updates][Restart Lowtide][Reboot AppleTV]

[About] -> About nitoTV, nitoTV version 0.6.4 AppleTV2,1 Jan 21st, 2011 (followed by a change log)

 

After installing a few apps, no new interface menus showed up, so I assume the tools must be used through an SSH command prompt.

PuTTY from Windows -> to the IP address in AppleTV2 -> Settings -> Network

 

NOTE: the inital connection is VERY slow, possibly new public private keys are being generated, and/or the client DNS is being looked up for most of us behind a NAT device and not registered, fails.. but a prompt still appears to auth by password (also note usual first time unknown host prompts from PuTTY).

 

After installing BTstack found that far over under [Settings] is a new menu called [Custom Settings] just click down and it "appears" out of no where.

Inside that is [Settings][BTstack]

Inside that is [BTstack][Devices][Searching...]

It found my Mac mini silver bluetooth keyboard and started a paring session automatically.

The Bluetooth keyboard now works to control the AppleTV just like the remote, arrow keys, esc, enter, ect.. just like you think it should.

Awesome feature.. the keyboard works perfectly for entering in password, search terms, anything into the dialog boxes that popup and expect you to type something in. So it's Bluetooth right? It can sit pretty far away from the black hockey puck and gives you a nother type of user input.

Next.. it also detected my Bluetooth MightyMouse.. though it didn't pair with it.. not sure how its supposed to.. perhaps the mouse has to go into a paring mode? Anyway there isnt' any generic app that I know of that could make use of the mouse input.. so maybe its just as well.

 

The VNC Server works flawlessly in protected or "open" mode to "share" the AppleTV display with a remote VNC client.. I used TightVNC on a Windows PC and Pocket Cloud on a Nook hacked to run apps (its an Android VNC client app).

The VNC Server does not apparently send multimedia content.. but I think I read somewhere someone figured out the flaw and had it working now.

 

The only cooler thing would be a VNC client "for the Apple TV2".. as I've lamented before.. and read I'm not alone in that assessment.. hope that comes along soon.

 

 

I ran things with both the power and usb chords plugged in at all times. Just pressed menu+down to restart and then the menu+play. Clicked on Jailbreak. It did its thing and I clicked complete. Waited and that was that.

I suspect I could have done this by powering off ( pulling out the power) and then plugging in the usb, menu+play, jailbreak, etc... This is the usual way. That is there is no need to have the power plugged in during a jailbreak even if it did work for me. Many users have not plugged it in. 

I also didn't find timing to be as crucial as you are describing. Maybe atv2's are different.

 

philip