Error when trying to connect Time Capsule

Apologies, since I’m sure this has been asked before. I’ve been banging my head against the wall trying to Add Share my 3rd generation Time Capsule. The ultimate goal is to access media files on an external hard drive attached to my time capsule but I can’t get access to my time capsule. I’m using the new apple tv and infuse 6. My MacBook pro is running macOS High Sierra. Everything works well with plex but would rather use infuse if I can get it to work. I’ve used my computer username and password, my time capsule username and password. I created new usernames and password, but nothing has worked so far. Can anyone help??!!!
I get the standard error after entering my information and hitting save
An error occurred
Sorry, infused encountered an error while trying to connect

Welcome to the forum!

To access your TC, are you trying to set up a share through your MacBook, or one directly to the TC?

With Infuse you can go direct to the TC, so your MacBook won’t be needed.

The TC should appear as an ‘Available Share’ in Infuse, but it may have a different password than your MacBook.

For AirPort Extreme and Time Capsule

  • Username is admin
  • Password will be the Disk Sharing password, which may be different than the Wi-Fi network password

Thanks for your response James! While waiting for a response last week I tried again… It allowed me to connect but did so stating and error again. I thought since I was connected I’d be all good but when I went to add a favorite folder but it kept giving me errors. I then deleted the app from both apple TVs and reinstalled. For some reason I had to pay again (24.95 I think) and reinstalled the app. Added the TC again (again with the same error but it connected and showed in the saved shares), and when I went to add a folder I got the same error message as before. An error occurred
Sorry, infused encountered an error while trying to connect. I’m going to have to end my subscription if i can’t get this to work right away.

Sorry about that.

If you are able to send in a quick report form your Appel TV we can take a deeper look at what may be going on.

Hi James,

I am facing the same issue. HD attached to Time Capsule works flawlessly for a certain period of time and all of a sudden I would get: An Error Occurred. Trying to reconnect to the drive from that moment is impossible without deleting the app from the Apple TV and start again.

Opted to use Plex but wonder what happens if I turn my iMac off and if that connection works.

What do you guys feel is the best NAS solution to stop using the flaky Time Capsule+External HD solution?

Thanks,

Roland

Hi. Had the same problem when upgrading to 4K Apple TV (after using Infuse / TC + HDD flawlessly for years) and fixed it by changing the way the TC disks are secured in Airport Utility -> TC -> Edit -> Disks -> Secure Shared Disks -> With Accounts -> Username: admin Password: whatever

Hopefully it continues to work!

Thanks! Will give it a try asap!

I did notice that the connection error always appears after there is an TVOS AND/or Infuse update… @james

Hey, Tried BFN’s solution with no luck. I got the latest TC thinking that my older one wasn’t compatible. I still get the same error message. I’ve been using plex and it works great I just have to keep my computer plugged in and on all the time. I changed the setting so the hard drive would not sleep if plugged in. I’m open to trying any other solutions if someone has any other ideas

One more reporting the same issue on same setup. Need a fix please. Conntecting to AppleTV on Infuse6 which is linking to a time capsule that has a 4TB USB disk attached for media. I end up restarting Apple TV to fix the issue but It happens within episodes and is annoying. Seems like Infuse can’t keep disk running and loses connectivity.
Edit: Correction clarity.

Don’t have the airport or time capsule but I recall hearing about an interference issue affecting these. Just a suggestion but maybe check out the section of this apple link https://discussions.apple.com/thread/2508959 and try a few different channels to see if that may help. Also heard something about disabling or changing IPv6 settings that may be a possibility. https://www.appleworld.today/blog/2015/12/18/how-changing-one-setting-on-an-apple-airport-extreme-fixed-all-of-my-network-problems

Again, not an owner of these but had seen some positive results using the above suggestions.

Thanks for the suggestion NC. Minor correction, I am connected to Time Capsule by ethernet which hosts a 4TB USB so it is not a wireless issue. This seems to have happened after the recent update.

As I wrote earlier, the disconnect always happens when Apple updates the Apple TV software and/or when Infuse updates their software.

I’m facing the same issue. Seems last two versions is broken.
PS version for iOS also not working with smb

I have the same issue… Can’t connect to my AirPort Extreme shared disk on AppleTV, but on my Mac I can… :frowning:
And I just tried on iPhone, and there it’s working fine!

… and again today: updated Infuse to latest version and getting error message. Only way to get it back is to remove Share and set it up from scratch. @james???

Yeah, mine started doing this today. It was working fine last night, then the internet went out today. When it came back on Infuse6 won’t connect. I see it in the sharing list, File Explorer connects fine, clunky interface, but it works. I have tried deleting the app, deleting the saved shares, everything I can think of, nothing happens. It’s not working on my Apple TV, iPhone, or iPad.

I think this is actually an issue with the cruddy device that is the Time Machine. I just did a full factory reset (including wiping the backup memories) and not only are all my devices connecting better, but infuse is working seamlessly.

I would agree, but everything else is connecting fine - File Manager, my MBP, iPhone, iPad - it’s only Infuse6 that is having a problem.