Error updating ATV Black on Mac

I’m getting an error telling me the ATV Black installer cannot continue.

The error states it is one of two problems:

  1. I am not connected to the internet. (I am)
  2. The installer is out of date and I need to get a newer one.

This one was released today… I don’t think there can be a newer version so I’m not really sure how to proceed.

Help?

See my response on this thread: http://firecore.com/comment/63996#comment-63996
Let me know if it worked!