Error on Favorite Folders

Hi there,

Since the last update there seems to be a problem with Favorite folders. I have an external hard drive connected via USB to my Time Capsule which is connected to my Apple TV2. Since the last update, I haven’t been able to reach the files on my external hard drive through my Apple TV2.

Suddenly I found out that the problem was that my external hard drive was set as a Favorite folder (so it’s shown directly in the top menu). Every time I tried to reach the files it prompted: “Could not open dir [smb://name]. Reason: No such file of directory”.

But then I tried access the folder through My Files -> Time Capsule -> External Hard Drive and boom - it works. Now I’ve tried both ways multiple times and every time I connect via Favorite Folder (yes I have tried to unfavorite it and favorite it again - no effect) it prompts the error. But it now works every time I connect via My Files it works every time.

Just wanted to let you know of this bug - please fix it.