Error message: "sorry infuse encountered an error while trying to connect" (Infuse 5.9.1 (2553), Apple TV (4G), Mac OS 10.14)

I’m running Infuse v5.9.1 (2553) on my Apple TV (4th generation). I have video files located on a volume mounted on my iMac which is running Mac OS 10.14. Despite following directions carefully, I am unable to connect to the shared volume on my Mac.

  1. File Sharing is turned on on my Mac.
  2. My user (which is an Admin) has Read & Write access to the Shared Folder.
  3. "Share files and folders using SMB" is turned ON.
  4. Windows File Sharing is enabled for the user account in question.

I have tried all of the options under SMB Version setting; every one results in the “Checking connection…” screen and then says, “Sorry, infuse encountered an error while trying to connect.”

Please help. I originally posted here ("sorry infuse encountered an error while trying to connect" Error message -- Infuse 4 on Apple Tv) and was told to create a new thread. Here I am. What am I overlooking?

It might be an SMB issue on your Mac. From what I remember only SMB3 is supported on the Mac. I had a similar issue with an android box and ended up installing NFSManager and running everything through NFS. Alternately you could install plex media server and share everything to Infuse that way.

What do you mean by “an SMB issue”? Can you be any more specific?

Mac will support SMB 1,2, and 3.

You do not need to install Plex media server. Infuse functions wonderfully without Plex.

I’m having no issues on an iMac using SMB set to auto, some find that setting SMB to Legacy works better for them.

My guess is there is an issue with user and password or settings in the sharing set up.

To the OP, which mac are you using?

I’m running Mojave (Mac OS 10.14) on an iMac (Retina 4K, 21.5-inch, Late 2015).

You may want to go through this page to make sure you have all the boxes checked

I’d recommend setting up a new user just for Infuse in the Mac system users prefs and make sure that user is selected in the windows file sharing box under the advanced options in the Mac system sharing prefs. Also make sure you have Share files and folders using SMB checked.

Well, I can’t explain what did it, but it’s working now.

I created a new user, just for Infuse, as you suggested. Perhaps that fixed things (but, if so, I don’t understand why). I also removed all of the other users from the Sharing Settings preferences. I suspect that was what helped: I have used Infuse successfully before with some of those users… removing them probably erased a config file somewhere.

One last possibility: I renamed my iMac and made sure there were no spaces in the name. That could have done it, too.

Anyway, thanks for your help. :slight_smile:

I’m convinced that sometimes shear perseverance solves some computer issues. You just tire it out till it submits. :wink:

My guess is that you got it with a new, clean user. The computer name change may have been a part if it too.

Glad you back on track and enjoy!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.