"Error merging boot.efi..."

Greetings!

I don’t seem to be able to create my flash drive. I’m using the PC version of the installer, with a thumb drive I’ve previously had success with on the Mac side.

When I run the installer, it asks me whether I’d like to download or locate the necessary file. I click on download. It then flashes that it’s downloading for about .5 seconds, and then says it’s creating the drive. Then I get the following error:

Error:

Error merging boot.efi into final image file. Error in file copy.

What does this mean? How can I fix it?

Thanks for any help in advance.

This may be caused by a few things.

Check the following:

  1. Extract all files contained in the zip file prior to running the installer.

  2. Make sure the bin folder and aTV Flash Installer are in the same location. Do not separate them.

  3. Also make sure you have at least 1GB of available hard disk space for temporary storage.

If you see a file name ‘Temp.dmg’ in the aTV Flash folder, remove this file and re-run the installer.

Sorry, but none of these are applicable.

  1. why one earth would I only extract some of the files?

  2. the installer and the bin folder are in the same location. again, all your documentation warns to keep it this way, but I’m not sure why anyone would separate them.

  3. I have over 37GB free.

  4. there is no file called temp.dmg anywhere

Again, none of these appear to even address the symptoms I’m seeing. It looks like the problem is that the installer isn’t downloading the dmg file. Any tips on that?

I got the exact error on my second attempt. Double check that you have not downloaded the temp.dmg file yet because this only happened to me when the file has already been downloaded. I was able to resolved this by moving the temp.dmg file elsewhere and just locating it when prompted. As soon as I moved this file I didnt get the error anymore.

I have the same problem and have tried various USB sticks in case that was the problem but everytime I get partway through the Flash Drive Creation I get the Error Merging Boot.efi message. Have tried contacting the support team but as yet they still haven’t been able to tell me why it won’t run correctly or how to fix my problem. Anyone else managed to find a way round this?

SUCCESS: I had the same problem. First time: Click on Download for the APPLE TV Update software when requested. A Temp.dmg file will appear. It must completely download…it make take some time…183,712kb. When it is completely downloaded, I moved it to the desk top…out of the unzipped folder. Ended install process. Second Time: I clicked on the Installer again to start again. This time when it asked for the Apple TV Update Sofware…I clicked on locate and selected the moved dmg file on the desktop. The installer took a while to examine the file and then it completed creating the flash drive…success.

OKAY, asking tech support wasn’t very helpful… just answered the typical checklist stuff which is already in the instructions.
I used the filemonitor.exe tool to see what was actually happening at the moment the error occured. The answer was found fast and clear. Insuffient temporary disk space on my windows C harddisk. Although I still happend to have 300mb spare spaced the error was pretty clear.
I cleaned up my disk a bit so I could get more free space. rerun the creation usb stick program and it all went smoothly.
Hope this helps :mrgreen: