Error entering DFU mode

Hey guys, so im trying to jailbreak my ATV 2 running 5.3.

I have the latest Seas0npass, iTunes, drivers, etc.

When I try to jailbreak it gets stuck on the upload screen and then I get a pop up that says “error entering DFU mode”

I have tried different usb ports, and different micro usb cables.

Any help is appreciated.

Thanks!

Try upgrading to latest firmware using iTunes before jailbreaking.

I thought that you couldn’t jailbreak anything higher than 5.3 though. Am I mistaken?

You can (currently) jailbreak from any version to 5.3 without saved blobs. In other words, the version you are currently running is irrelevant.

So i updated the firmware in itunes, tried ita again, but im still getting the same error

Are you sure it’s an ATV2 ? Are you using a MAC or PC?

One way around this is see if seasonpass created a .ipsw file (do a search of your computer). If it did, put your ATV in to DFU mode, open itunes. hold shift+click restore, then choose that created file.

Its an AT2 I’ve jailbroken it before.
I am on a pc and i dont have a mac available for my use,

Also i tried to just restore the file in itunes, and it just gets stuck on the “Verifying restore with apple”

Did anybody find the solution for this issue? I am facing this issue now.