Error connecting to Jellyfin server

I run Jellyfin server on a 2020 M1 MacBook Air connecting with Infuse on my Apple TV 4K.

When I add the Jellyfin share to Infuse, everything works as advertised. But when I leave the TV and return after a bit, Infuse gives me a error connecting to server message. Sometimes when I am browsing the Infuse library, the server will kick me off with the error message.

I’ve tried tweaking my network settings on the router adding a DHCP reservation to the MacBook Air and port forwarding 8096 to the MacBook Air. Same errors from time to time. I am not heavily into networking, but just feel like their might be one setting I am missing. All suggestions appreciated.

Have you tried setting the computer sleep time under the Energy Saver preferences on the Mac to never and put hard disk to sleep when possible to no?

Does the connection start working again at some point, or does it refuse to ever work again?

Are you using the device name (EG My-MacBook.local) or IP address for the saved Jellyfin share in Infuse?

Yes, that was my first thought. The Mac is set to never sleep. It has an SSD so no option to put the hard disks to sleep. I have had no trouble sharing the desktop on the MacBook Air anytime that I have tried, so the Mac seems to be always awake.

I am using the IP address for the Jellyfin share. I was using the MacBook.local name and thought that might be the problem. So I added the DHCP reservation and changed it to the IP address.

Once the connection is lost, I can usually get it back by signing into the Jellyfin server and then trying again on Infuse.

My inclination is that there is some kind of timeout thing happening, but I don’t know what else to check.

I found the cause of this problem. The culprit was the dreaded “MacBook goes to sleep with the lid closed even when you have it set to stay awake.” Came across a discussion of this behavior on an Apple forum and tried the very simple (and obvious) test of leaving the lid open. Problem solved!

2 Likes