Error: Cannot launch XBMC/Boxee from path

I’ve tried every tip I can find here but still cannot use XBMC or Boxee. Both fail to launch with a message like this:

Error: Cannot launch XBMC/Boxee from path:

I an using the aTV Flash version and there has never been any other third party software on this ATV. These two programs have not worked from the beginning, and I have no idea what else to try.

I’ve tried uninstalling and reinstalling them, to no avail. I have seen a few other questions about this in the forum that have not been answered, so there must be others with the problem.

Is there a fix for this issue yet?

I had that message the other day, so made sure I had uploaded the latest to both /Applications and /Users/frontrow/Applications and now it works OK - not sure which fixed it …

I’m using the aTV Flash version of Boxee, NOT the one that you have to download manually from the Boxee website, so I don’t think that is the problem.

same issue for me here.

i had this problem. i downloaded again from the download option on the menu. restarted the finder and they finally worked.

I’m having the same problem. I have tried downloading again and again and restarting my device, but the same error keeps popping up.

Hi Moto

I am having the same problems as you, can you tell me if you found a solution.

Howto Totally Uninstall Boxee/XBMC:

  1. Open your SSH client program.
  2. At the command line prompt ($), type in the following:
    • ssh frontrow@your.appletv.ip.address
  3. You might be asked if you are sure you want to continue connecting (yes/no). Type yes.
  4. You will be prompted for a password. The default password is frontrow.
    • frontrow
  5. Type in the following one line at a time:
    • sudo rm -rf /Applications/
    • sudo rm -rf /Applications/
    • sudo rm -rf /System/Library/CoreServices/
    • rm -rf /Users/frontrow/Library/Application\ Support/BOXEE/
    • rm -rf /Users/frontrow/Library/Application\ Support/XBMC/
  6. You should now reinstall Boxee/XBMC from scratch.

This may be a basic question, but can you tell me how do I go to Terminal on My ATV? What is the SSH client? Is there another FIX?


that worked smooth (well, relatively speaking…:-)), however although the menu for XBMC/Boxee is gone from the AppleTV, in Maintenance > Manage Plugins XBMC/Boxee shows as “installed”. Clicking on >>| on the remore brings the “remove XBMCLauncher?” dialog, but choosing “remove”, then restarting the finder doesn’t help
I guess I should have done this first before forcefully remove it by ssh, but… here we are now.

So how do I “reinstall from scratch”?


any ideas? any other forums to look for help?

 to let everyone know, I bought my appletv in Sept 2010 with 3.02 and just applied the current atvflash onto it - the error Error: Cannot launch XBMC/Boxee from path: /Applications/ is still happening.

I will try tonight to uninstall it from the appletv, completely remove it using SSH, then see what happens.

If that doesn't work, then I'll try downloading the boxee app from and upload it to the appletv manually.


This REALLY SUCKS as we paid $50 to have this experience.  I feel ripped off, as I could have enjoyed the hacking experience for free - I could have compiled the atvflash tools myself with all the free stuff out there.


 I had this problem too but realised my mistake pretty quickly.


You must go to the Boxee/XBMC menu and then go to downloads, choose which version you wish to use and then select it. This will download the full application which will now work. do this for both Boxee and XBMC.

thanks @luked.9705

looks like additional entries were added to the Downloads menu since, those for sure weren't there before.  there were only two entries, now there are 2 options for boxee and 2 for xbmc.

I chose the latest boxee beta version available through this Downloads menu and now it works perfectly.  good.  problem is fixed.

Me too.


Unfortunately mine required a complete reinstallation of both the basic Apple TV OS and atvflash.. I had tried the installation method given above but it did not just seem to stick .

Disappointed to see ATVflash not giving more response on this so far. This and lack of response on multiple other issues make me glad that I have only paid for a two year option with these folks.


I have had this experience from the start with this SW - a fantastic idea that seems to have just stuttered along without much buy in from the folks I am paying money to. Get off your arses chaps - start replying to your users posts.

The (old) ATV (and possibly new) has the ability to unlock many things that other multimedia boxes do not, ie live tv, iPhone integration, XBMC extras, multimedia format and even (!) the ability to sync with iTunes. I see little on Firecore’s site explaining these extras which you sell in your sales blurb with in depth explanations just a basic KB and forum.

Apologies to others for the rant - I am just kinda tired of googling this all…

Pitch up!

Tsk, tsk…

Agreed. I already tried the open source version and after wasting hours on it, paid for ATV Flash on the basis that everything would work as it should without further hacking. 

As with you, I spent hours more trying to solve this issue with Boxee/XBMC and also having to install Flash, which a few words could have helped with. After searching around and finding this fix, now Boxee seems to work but I am getting messages about Adobe AIR needing to be installed - why is this application so buggy?


I seem to have sorted the “error cannot launch” problem

Go to XBMC/boxee, downloads, click on dharma… Then it shld work.

Ps: I really share all your frustrations on this. Good luck!

Pps: does anyone know how I can now read my external hard drive???