Error after installing Crystal HD

My Broadcom Crystal HD BCM70015 arrived this week and I install it in my ATV 1st gen by following the procedures stated in another forum:

http://www.bluefish.net.nz/2010/02/apple-tv-and-full-1080p-broadcom-card.html

After installation, I turned my ATV on and suddenly, the AppleTV with a flashing question mark appeared. I tried removing the crystal hd and reinstalling back the wifi, but still, the ATV with a flashing question mark appeared. Tried to make it sure that the cable attached to the harddrive was carefully removed and reconnected, but still, to no avail. 

Anyone who experienced something like this? Any help will be greatly appreciated.

A flashing question mark means the startup disk cannot be found.

You will want to open the AppleTV again and ensure the hard drive cable is securely connected.

I brought the Apple Tv in an apple store and they told me that the hard drive is already busted. Im surprised because prior to me installing the broadcom, my appletv is in good working condition. Could this be because of the broadcom? Anyone experienced the same?