Episode thumb not refreshing with local metadata

I had the series Star Wars Rebels in my library, but the TMDB series order doesn’t make sense. I used tinyMediaManager to pull a better order from TVDB. Now I have the right order, but the thumbnails are wrong. For example TMDB had “Droids in Distress” as Season 1 episode 1. With the new metadata it is episode 3, but the thumbnail for episode 1 still shows that thumbnail rather than the one in my folder labeled as “Star Wars Rebels S01E01-thumb.jpg”.

Many times I have clicked “Scan for changes” and “Refresh Metadata” but it doesn’t update. I don’t know if it sees the same file name and just assumes it has the latest image or what. I tried pulling the thumb for the first episode to a different place and then refreshing metadata, putting it back again and refreshing again, but no luck.

It would be great if there were a way to force a metadata refresh for a single title. That would really help when setting your library up for the first time as I often have to make changes to file names or metadata to get the result I want.

Try doing an “Edit metadata” for the episodes you want to update and re-select the correct show instead of the refresh metadata.

Edit to add: See my following post regarding file naming before you go through the “edit metadata” routine.

Also, you’re not using the correct naming for the graphic file.

If your File name is

“Star Wars Rebels S01E01 720p.mkv"

Then your graphic for the E01 episode should be named:

“Star Wars Rebels S01E01 720p.jpg". (not with the word “thumb”)

Per the users guide:

Thanks for the tip! I used tinyMediaManager as in the instructions, but they didn’t specify which NFO format to use. I stuck with the default, which is Kodi. I don’t know if it would name the graphics differently if I changed it to, say, Plex.

I changed the names of the image files and then refreshed meta data. That didn’t work. So I did “Edit metadata” for the episode and chose my .nfo file. That caused it to update. Kind of tedious for all those episodes, but at least it’s working.

Thanks!

1 Like