Endless Loop to Restart, Diagnostics or Restore

Just purchased ATV Flash & an approved USB Flash Drive. All seemed to go well installing ATV Flash on my ATV until I removed USB Flash and restarted as instructed. I have been in an endless loop since, each time I restart I am forced to select the language & resolution and then I am prompted to select

  1. Restart ATV (Which just puts me in the loop again)
  2. Run Diagnostic (Which states everything is ok)
  3. Restore (Which throws error "Restoring Factory Condition Failed)

I have just spent nearly a $100 for ATV Flash with 3 years and a USB Flash Drive for use on an ATV that won’t work.

What is a person to do? I am very disappointed!

UPDATE: I was promptly contacted by support and currently trying to resolve the problem.

Email sent.

I’m having the same problem…

Same problem here too…My atv was automatically updated to 3.0.2 :frowning: and I tried to reinstall aftflash and now I get this

An outdated version of aTV Flash may be being installed.

  1. Format flash drive (including optional step #4 if on a Mac) - http://wiki.atvflash.com/index.php?title=Troubleshooting#My_Flash_Drive_No_Longer_Works_After_Installing_aTV_Flash
  2. Download aTV Flash 4.0.6
  3. Install onto flash drive
  4. Install onto AppleTV

having followed your instructions, I now have the following error turn up:
Error merging boot.efi into final image file. Error in File Copy

I had the same problem as the stated above:

I appled and auto update on the ATV and then went and installed ATV Flash. I’ve been stuck in the same loop, where even a factory reset crashes out and now gives a ? above the ATV box on screen. I have a 160Gb ATV

Now fixed…

I reinstalled an image of my USB drive and put it in the ATV and got the following errors:

/dev/sda3
Checking HFS Plus Volume
Invalid B-Tree node size
0)
Volume Check Failed
*symlinking /mnt/rootfs -> /payloads
*keeping the OSBoot partitions R/w for plugins
Ch /OSBoot/readwrite:read only file system
*mounting media partition
/dev/sda4
Checking…(Five lines)
The volume Media appears to be OK
*error mounting Media partition

Hope this assists in some way…

I also have the 160GB (if that matters) and I am installing 4.0.6…

Yeah my appletv 160gb is no dead also. :cry: constantly rebooting, i have hooked an apple keyboard up to is and held down apple v
so you can see it booting and reporting lots of problems with Kext files, i assume permissions by the errors. then it flicks the screen showing “continue…” then reboots.
i left it rebooting for a while and it eventually threw back the user language setup screen, i think this is the automatic diag mode, but i was unable to control it with the IR or the still connected usb keyboard.

i then left the appletv in this mode and after about 5 mins it decided to reboot by itself now its back to the endless reboot loop again.

it would be nice to have a fix soon as i bought the lifetime updates package. :cry:

HELP!

Has you internal drive ever been modified?

Based on the installation text shown above, it seems you are using something other than aTV Flash.

I know you’re not talking to me but I’ll try to give out as much details as I can. My drive is the one that was shipped from Apple and ATV is the only thing that has ever been installed

Is this issue being worked on at all? I basically have a bricked atv right now :frowning:

Was the flash drive previously used to install aTV Flash? What version were you running before?

I believe I had 4.0.4 (which stopped working when Apple auto updated it to 3.0.2). I then I got the problem after I ran the installer for 4.0.6

You may try the steps below to ensure 4.0.6 is being installed, and not an older version. Following these steps will remove any previous versions of aTV Flash that are currently on the AppleTV. Your media/settings will remain intact.

  1. Format flash drive (including optional step #4 if on a Mac) - http://wiki.atvflash.com/index.php?title=Troubleshooting#My_Flash_Drive_No_Longer_Works_After_Installing_aTV_Flash
  2. Download aTV Flash 4.0.6
  3. Install onto flash drive
  4. Install onto AppleTV

You may try the steps below to ensure 4.0.6 is being installed, and not an older version. Following these steps will remove any previous versions of aTV Flash that are currently on the AppleTV. Your media/settings will remain intact.

  1. Format flash drive (including optional step #4 if on a Mac) - http://wiki.atvflash.com/index.php?title=Troubleshooting#My_Flash_Drive_No_Longer_Works_After_Installing_aTV_Flash
  2. Download aTV Flash 4.0.6
  3. Install onto flash drive
  4. Install onto AppleTV[/quote]
    Followed your steps with 2 different flash drives (the one I had used when I first installed atvflash and one I borrowed)

The installation says everything was updated fine but the next reboot takes forever and ends up taking me to the recovery menu

any update news?
i now have a bricked appletv due to ATVflash…

i had a though that the patchstick you make seems to have a script to check if the patch files are already on the appletv hard disk before patching them, how about changing it to recopy them then patch. if thats the problem then is might help? desperate now…

If you’ve tried the steps above and are still having trouble please send an email here:
http://www.atvflash.com/contact.php