“Empty” Shared folder - but it isn't!


what kind of report do you need? From which device?


kind regards

From the device you are having trouble with. Details on sending in logs from iOS or Apple TV can be found near the end of this guide. Troubleshooting and Getting Support – Firecore

There is only submit diagnostics and then show unique code. Don’t find any logs. When i share from router to infuse i see maps but when i open is empty. I also share right now 720p movie and work. I have 3 movies 1080p, one work, two don’t work. Problem is in infuse, because i share this to my macbook and work perfectly. What do you need from me, that you can check.


I have this problem almost everyday. Its kinda sad we see this thread since 2015 and its still here happening. I opened a ticket, ill help in anyway possible, lets hope there is interest in fixing this.

I have been using Infuse for a couple of years now and I am quite happy with the results, but I recently found something that I have been unable to solve so far. From my view it might be related to the problem on this thread, I think the particularities from my setup might make a good source for testing and solving the problem so here it goes:
I have 4 ATVs, same model, same OS version, same settings, same app version connected to a Synology 1515 through SMB. The synology has shared folders with about 2.000 movies and episodes that can be seen correctly from 3 of the ATVs. The fourth ATV is not able to see some of the shared folders, missing some completely and others partially.
Extra data:

  • The files that are not shown on the 4th ATV are varied in terms of naming structure and characters, format and size. Similar files are shown on the 4th ATV.
  • Connection infrastructure has been ruled out, they behave the same through WiFi, ethernet, and are not affected when switching cables or the router
  • Firewall and connection rules are empty, the NAS is not blocking any specific mac address nor any IP
  • Already tried deleting the APP, the data of the app, and resetting the whole ATV to factory default
  • The ATVs are synced together through traktv
    Edited: Also tried switching protocols to FTP and NFS with the same results

PS: I submitted the diagnostics data through code XHV3S from the faulty ATV
Editing: It might be related to timeout when listing, as the folders that fail contain great number of files, and the smaller ones are working properly.

After dedicating a few hours I have been unable to further narrow down the problem. Since I found out the problem in my case is related to the number of items per folder, I have divided them in smaller subfolders and now it is working properly. It is a pity to treat the symptoms and not the problem itself, but it works. I leave it here in case it may be useful for anyone else. I will also try to come to check later in case you want me to run further diagnostics. Cheers!

Since you have a Synology, you might try using NFS instead to see if this makes a difference. A side benefit is NFS will perform faster than SMB in most cases. :slight_smile:

A few quick tips for setting this up can be found here. Best speed between SMB and NFS? - #13 by james

Wow that brought me the answer of my problem. What a stupid problem. Infuse actually stops looking for videos if infuse seems to find mp3 files instead of looking further and looking for video files as well. One folder worked and the other didn’t. So the problem was at this folder their were besides videos als music files. Good lord … that took me forever to figure out. U guys should actually change that behaviour!

Hmm, Infuse won’t list the music files you have inside a folder, but having music files present shouldn’t prevent video files from being listed.

Did moving the music files out of this folder allow the video files to be listed, or did you end up moving the video files to a different folder?

I moved the 2 music folders out of the folder and then it immediately started to list videos in the folder. Before it was just empty (Proto sftp).

In fact the 2 folders did break the whole listing … even sub folders. I moved the 2 music folders firstly up in the folder tree and then this folder was also empty … I don’t know if it’s actually the music files or some encoding thing ? The server encodes utf-8 by default …

Hi all!

I’m having the same issue. I had set up years ago my Synology with Infuse. Some times had appear the Empty Folder error and after a lot of intents of change configuration works again.

But now is not possible to connect any folder. I try with SMB and NFS. I follow all instructions and options you posted. I have a user for Infuse with the permissions for the shared folders. I can set up the device correctly but when I try to add a shared folder says Empty Folder. Even that I try to setup with NFS and I can select the folders but are empty too.

It works perfect until yesterday when accidentally I delete the device from Infuse. Now is impossible to connect them again.

What can I do?

Thanks a lot!

I had ” Hide this shared folder in My Network Places".

After that I add the folders as Fav. and Hide again. Now works fine.

The issue in this is simple, I just solved it, it’s all about files names accentuation , it can be folders, files, or subfolders, I have my own FTP movies server with about 2k movies and it was all going fine until I added the movie file called “Pokémon” and started having this issue, the conflict is with the “é” I changed it to an “e” and as soon I changed the name it all went good, seems like infuse doesnt support that kind of characters so all you need to do guys is stick to standard characters

1 Like

Wow, you are absolutely right. I have the exact same problem with my FTP share on my Synolgy.

I did some further testing with a Pokémon folder and Pokémon.s01.e0x.mkv filename:

TV show dir + Pokémon folder + pokémon original filenames
FTP: Entire TV show share “empty”
NFS/SMB: TV show share + subdirs visible

TV show dir + Pokemon folder rename + pokémon original filenames
FTP: TV show share visible, all subdirs visible but Pokemon subdir gives an “empty” message
NFS/SMB: TV show share + subdirs visible

TV show dir + Pokemon folder + pokemon rename filenames
FTP: TV show share + subdirs visible
NFS/SMB: TV show share + subdirs visible

I know, I could change to SMB/NFS but my speeds are much higher with FTP (230 Mbps) vs NFS (50 Mbps) and I need the much higher speeds for my large 4K movies.

I think this issue has to be looked at further since there are shows/movies which have special characters in them and when they are downloaded automatically, problems will arise.

Beta Infuse Pro 6.3.4 (3000) on Apple TV 4K and Synology DS-216+ii

Edit: Sorry for the reply on this old post, but I felt the problem was still around. However, I dug around in Synology FTP and noticed UTF8 was disabled. Changed it to “auto” and everything worked as a charm again. Hope this will help other users as well.

Yeah I heard before that it was about the UTF-8 encoding but since I’m using a WD Mycloud drive I don’t have the UTF-8 option my settings so I had to stick to standard characters, wow I was stuck with this issue for more than a year ??