“Empty” Shared folder - but it isn't!

I just setup Infuse Pro on my AppleTV4.

I added a “Share” for my NAS (a Synology, for what it’s worth) via FTP.

I was able to login and make a favorite for my “TV” folder without issue.

Then I went to my “Movies” folder and Infuse told me that it was an empty folder.

But, of course, it isn’t.

However, I can’t convince Infuse of that. No matter how many times I try to open it, it always says that the folder is empty.

So I decided not to worry about it. I went into a folder in the TV folder for “Agatha Christie’s Poirot” and selected an episode (s1e1). Infuse immediately fetched the metadata, and showed me the episode information.

It started to play immediately and I was quite pleased with the results.

A few minutes later I decided to go back and check to see if Infuse could find my Movies folder. It could not. I verified that the folder was not empty using the FTP app on my Mac. (It is not empty.)

Any ideas what I can try to convince Infuse that the folder is not empty? I don’t understand how it can read from one folder on the NAS without problems but then another folder fails to work at all.

(Ah, computers!)

Hmm - any chance you have different usernames or permissions for each folder?

We’ve got a DS212+ here that works as expected for various folders/favorites, though this is usually done via SMB instead of FTP (though it should work ether way).

I had the same problem with Infuse and my Synology. Actually this is not a permission issue it’s an accentuation character issue.

In your DSM/Synology Console, simply go to > Control Panel > File Services > FTP tab > Force UTF-8 Codage

It worked for me.

++

I have similar problem. I have new Time Capsule 3 TB, aTV 64 GB and buy infuse Pro. I spend day to try setup this connection.
1/ When I have in Time Capsule at Disks tab default option for “Secure Shared Disks / With device password”, infuse find TC, but result is “empty folder” - but at root or at folder “Shared” is something. At infuse I set empty user/pwd, or try leave empty usr and enter device pwd to pwd field. (or try enter as user Administrator or guest). Result is same.
2/ Than I found, that when I use “Secure Shared Disks / With accounts”, I make accounts, set this account also at infuse and in this case this work.

Anyway my question is: Is possible (and how) use option 1 ?

added: I’m just try also “disk password” and this also not work.

Hy. Same issue here. With a Sinology RT1900ac in DNLA. I have to uninstall and re-install Infuse on my AppleTV to have have the content back. Could you help us?

Same issues:

Infuse v4.2 on two Apple TV 4’s running tvOS 9.0 and tvOS 9.2.1. I’ve tried tried both WiFi and Ethernet.

  • Music folder shows "Empty Folder: Move along, nothing to see here" in spite of the folder containing 2311 .mp3 files.
  • Photos folder shows "Empty Folder: Move along, nothing to see here" in spite of the folder containing 448 .jpg files.
  • After repeated, unsuccessful attempts to get a support response via email, I stumbled upon the solution: I deleted Infuse and installed Plex. After a week of using Plex (see: https://plex.tv) it has worked flawlessly with no problems.

    Couldn’t be happier with this “fix.”

    This is expected behaviour. At the moment inFuse will only recognise video files as something it knows how to play.

    I know that support for music only files (e.g. Mp3) is a roadmap item but we have been told that there is no ETA and that the next few inFuse releases are going to be about improving the video experience.

    Not sure I have seen a similar statement about support for Photos.

    Ahh cool… An app that is expected to not work, and the developers ignore support requests. Glad I moved on to one that works, maybe someday down the road I’ll revisit Infuse and see if they’ve got it working.

    Why would you expect it to work? It describes itself as a video player, not a general purpose player of any media type. In other words it does what it’s App Store description says it does, not what you assumed it does.

    I agree that support free standing audio and image formats would be a welcome addition. However it will require major enhancements to the current User Interface to support these in a meaningful way. In the meantime I use File Explorer for playing these file types.

    I was under the incorrect assumption that Infuse was a “media player” as opposed to strictly a “video player.” That’s nobody’s mistake but mine.

    A response to any of my support requests informing me of this was probably asking to much, but either way I’m quite happy with the features of what I’m using now and as previously stated perhaps I will revisit Infuse in the future.

    I definitely like Infuse’s GUI over Plex’s.

    I am having the same issue, but only intermittently… I can be watching a show and when the show is over, go back to the folder and I get the same goofy message.
    If I close out infuse then go back in, it’ll read the folder with all the shows. Sometimes it just does it even when I first go into infuse.
    I was wondering if it happens when the HD goes to “sleep”…? Does it timeout when trying to read the contents of the folder? Does infuse not cache the folder contents locally?

    I am running a shared drive off my Apple Extreme wifi router. With a login and password for the entire drive, not individual folders.

    This is the EXACT same problem I’m having, same set up as well. Sometimes even just editing metadata will result in the screen displaying the “empty folder” error after submitting the change. On the most recent version updated August 2016.

    For me, I solve the problem by renaming some files without their accented characters.

    Same Issue

    My “favorite folders” can sometimes see my files when the library can’t.
    And sometimes I cant see any files in either the favorites or library.

    I have the exact same issue with infuse 4. With infuse 5 i cant even add favorites. I’m adding tr share without any prblems with user and pass, but when i try to add favorites I’m getting empty folder.

    Yeah, right, same issue here. And we’ll never get support from Firecore. They just ignore this problem.
    Infuse 5 pro here.

    This guy seems to have a possible answer; I’ve found out directories with interrogation marks makes infuse go crazy. Could someone make this test and change ALL non common characters on every directory and file?

    I’ll also doing this, but, since I’m Brazilian (and we have LOTS of accentuated characters) and I’m using a 8TB HDD with only 500mb of free space.

    Would be amazing if we, as a team, could resolve this issue for good.

    As I said before, Firecore isn’t helping anyway. They just suggest obvious answers and play us dumb.

    Ok, I tried renaming all my 8TB files; still having the same problem.
    Tried using different accounts (from admin to username)
    Tried using different connections (cable & wifi)

    EVERYTIME I KEEP THE MESSAGE “EMPTY FOLDER” AFTER SOME MINUTES.
    IT WORKS PERFECT TILL I GET THE GOD DAMN MESSAGE.

    FOR GOD SAKE, FIRECORE, GIVE US SOME HELP!
    WE PAID FOR THE APP AND DID EVERYTHING AS U GUYS SAID.
    THAT’S JUST NOT FAIR, U HAVE THE BEST APP ON THE WHOLE WORLD BUT IT JUST DOES NOT WORK AS EXPECTED!!!

    hello. i have the same problem. I share files from asus router to apple tv and some folders show empty (but it isn’t). I change name of folders but problem is still here. Files are movie in this quality BluRay.1080p.DTS-HD.MA-5.1.x264. What can i do? I wont share from macbook to apple tv. I have router for this. Please help

    thanks

    kind regards

    If you’re able to send in a report from your device it may help us track down what’s going on.