empty repos help

hi all, for some reason my atv2 f*cked up on me so i restored, re-jailbroke and installed xmbc through nito, the problem is i cant add any repos, using cyberduck on mac to ssh them but all repos are showing empty when i install them, tried using the gosub repo through the atv aswell and thats showing empty too, ive googled it and somewhere suggests deleting the addons.db files in xbmc, tried that to no avail, restored and repeated everything and still cant get it, anyone got any suggestions as to what im doing wrong?? hope you all understnd what i mean, cheers!

update: ive got navi x on it now, im trying to get the 1channel add on, the only place i can find it is on the bstrdsmkr repo, when i try to add it i keep getting “add on does not have correct structure” can anyone help me with this???

 

If I were you, i’d recommend just rejailbreaking your ATV2 and starting from scratch.

I figured it out, I was downloading all the repos on Firefox which was the problem, downloaded them via chrome and they worked no problem