Emby & Jellyfin multiple versions of a movie

I can’t select the version of the content when I play movies or tv shows from Emby server, I only can play the default version.

I moved your post to a currently running thread for the suggestion.

Don’t forget that you need to click the like button on the first post in this thread to show your support for this suggestion! :wink:

I came by this Apple TV 4k app http://squireapp.com/ and what i like is, they have an option to select server to play the file.
Example:
1). All movies and TV Shows are there together from all servers combine, when you click a file to watch, it ask you from witch server to watch from. It tells you wich server have that file and dislays resolution.
Would you add this option to infuse as well.
Thanks

+1 please!

Is there any update as to whether this will make it into 7.5 as per @james comment here? Multiple versions of a movie - #197 by james

These will be the threads to monitor for status.

I’m aware of those threads. James has explicitly said he’s hoping to introduce this feature in 7.5, so I’m asking for an update on that statement. Thanks though…

Since it’s not in progress yet and not shown in the threads I referenced I’m guessing it got moved back some.

It has never been referenced on the threads you linked, and yet James has said it will hopefully be included in 7.5. Maybe we’ll see if he can give us an update, instead of guessing :person_shrugging:

So we can now say it’s not included in the 7.5 release so hopefully it will get on the schedule soon :slight_smile:

I am running a Jellyfin server and for the most part everything works great.

But Jellyfin and Infuse both use different methods of discerning versions of the same movie.
Jellyfin’s solution is to add ’ - ’ followed by user determined tag (ex: ’ - 1080p’, ’ - Director’s Cut’, etc.) This doesn’t work via Infuse.

Using Infuse’s method of ‘{edition-1080p}’ works on Infuse, but doesn’t work via Jellyfin’s WebUI. I’ve tried various ways of trying to combine the two to see if I can make it work somehow, but to no avail. Funny enough, when dealing with 1080p/2160p versions and having the smart grouping setting set to select the highest quality, Infuse does seem to default to 2160p content when streaming, even though the actual metadata on the Infuse app depicts the 1080p version. This, however, does not apply to bitrate, where both versions are the same resolution and one is a lower bitrate than the other. During my testing, Infuse will just read the first nfo listed in the directory and go with that.

Does anyone have a working solution for this - or am I stuck with picking one over the other? Any future plans to make this work somehow?

Jellyfin’s method: Movies | Jellyfin

1 Like

It’s still not implemented, and from the planning topic (Upcoming Features (updated 7/8/23)), there is no sign about any implementation.
Is it still planned ? Could we have and ETA maybe if it’s still planned ?

This would be much appreciated, thanks

All of your answers are in this post as to status of suggestion and any available dates for public release. :smiley:

So I guess the short answer is No, it is not planned and there is not ETA.

You need to read the post referenced, this thread IS marked as “planned” and per the referenced post,

With all of the variables involved in development it may be a moving target but it is a target. :wink:

This will all be irrelevant once Infuse releases it’s new plan for working with external media centers

I’m not aware of what you’re talking about (new to the forum).
Do you have any post that explain more what you mentioned ?

2 Likes

Not necessarily.

1 Like

I agree, making direct connection doesn’t ensure that multiple file version will be supported.
Also, direct connection is far away from being enabled by default i think, so it would be nice if they could take the time to implement it in the current version.