Embedded metadata not recognized

It seems that things are needlessly confusing and unnecessary.

Here is my situation. I have a library of 2000 movies with meticulously curated embedded metadata. Infuse states that it can use embedded Metadata.

However, the library sorts 1 of them into the Movies category, and leaves the rest as “other” … despite the fact that they are all properly tagged as Movies in the metadata.

Does Infuse intentionally ignore the media-type tag in the embedded metadata?

Please don’t reply with a totally pointless “just use metadata fetching”. I use embedded Metadata because this way I know the information is correct. Any time I have relied on cloud metadata fetching I inevitably lose information, or someone inserts a hyphen that doesn’t belong, or the regular version gets its cover-art swapped (for example every time a new box set of Alien(s) gets released with newer artwork …( even if that new version has new scenes and thus doesn’t relate to the version I have) or all of my versions of The Abyss end up identically tabled as “the abyss” without the “theatrical” or “special” or “james cameron needs more money” portions of the title (all of the above are actual examples of what has happened using Infuses fetching of metadata from online sources.

This even happens if I turn on both embedded Metadata and Metadata fetching … is Infuse not capable of using my embedded information where it exists and only using online sources where information is missing?

Is your metadata actually encoded into the video file or do you have either an xml file or nfo file along with artwork files for the video file?

it’s all actually embedded in the file … infuse reads it just fine because if “fetch metadata” is turned off, I see everything as I’ve tagged it, but like I said, all but one show up as “other”

I also don’t want to use sidecars like .nfo or xml or anything else … that immediately makes my files less portable, and only increases the number of files I need to maintain.

Have you let Infuse complete a scan of your files? You can see the progress when you go to the Library settings page and it will tell you the status.

Do you see a “Last Updated:…” message? If so have you tried the “Refresh Metadata” option on the Library settings page and watched the status until it comes back with the “Last Updated:…” message?

yes, all scanning is complete … I’ve even sat and watched the screen during the whole scan so I know it is done. I’ve done it 5 times, and every time it does the exact same thing …

I know you need to ask the “have you tried turning it off and on again” questions, but I’ve done all that already.

I really hope that this poor functionality isn’t deliberate to force users to cloud metadata for the purposes of data harvesting … :frowning:

There is no “deliberate” poor functionality, if you’re experiencing a problem then chances are there is a setting somewhere that is causing this or there is an error in the reading of how you have the data embedded. There is no nefarious cloud data harvesting.

Not having your files and settings in front of us we have to ask questions based on what we’ve seen with past user problems and try to formulate a solution.

Have you browsed through the share containing the movies, not in the library but the saved share? Actually scrolling through the movies and letting the artwork load? Sometimes if Infuse has loaded metadata and there are updates it may not look for it until it’s needed such as browsing the share. It may take a few minutes for it to update once you’ve rolled through it.

1 Like

In order to use Infuse’s library features you will need to have Metadata Fetching enabled.

If you prefer to use your own metadata embedded in your files, then you can also enable Embedded Metadata.

With both options enabled, Infuse would look for embedded metadata first and then use online metadata to fill in any missing gaps.

That may be what you intended. but that is most definitely not the experience I am having. Infuse consistently overrides my embedded artwork and titles.

As a customer can you please answer the following questions:

  • Why must I let Infuse use substandard/downright incorrect metadata to have the library feature?
  • Why must I let Infuse override my correct artwork with incorrect artwork to have the library feature?
  • Why must I let Infuse rename all my editions of Blade Runner to “Blade Runner” (and give them all the same cover art) in order to have the library feature?
  • Why must I let you share my data with others in order to use the library feature? I am PAYING you.

I did a few quick tests, and was able to confirm there are some embedded fields that are not getting recognized as expected in the current version when both Metadata Fetching and Embedded Metadata are enabled. This appears to be a bug which was introduced in a recent update, and something we’re looking into. Thanks for pointing this out! :slight_smile:

With regard to data sharing, Infuse does not collect or store any info about your files. When using online metadata, Infuse will send title info to TMDB for search, but this is done anonymously without sending any personal information.

A post was merged into an existing topic: Use embedded metadata to categorize items in Library

10 posts were split to a new topic: TV shows with embedded metadata appearing in Other