**EASY**Downgrade to 4.3 firmware on apple tv 2

It took me almost a week but I finally figured out how to downgrade from any firmware to a previous firmware that is no longer being signed by Apple. This is for those of us that purchased an apple tv 2 that came with a version of iOS newer than 4.3. Thus, no SHSH blobs are available for the downgrade.

In my case, I needed to downgrade from 4.4.4 to 4.3 on an Apple tv 2 that my friend purchased about a week ago.

These are detailed instructions. If you have trouble, start over from the top.

Step 1:

Find your “hosts” file on your computer.

For a mac, it will be in /etc/hosts. **NOTE: You may need to change your mac settings so that you can view hidden files and folders.

               To do this, open up your terminal and type: “defaults write com.apple.finder AppleShowAllFiles TRUE” without the quotes and hit enter. Open up finder and                     you should now see all of your hidden files. To turn this off, re-type the same line in terminal but change TRUE to FALSE.

For a pc, your hosts file will be in c:\windows\system32\drivers\etc\hosts

Open your hosts file in a text editor and add the following line to the very bottom of the hosts file:

          # gs.apple.com

Step 2:

Connect your apple tv 2 to your computer. If iTunes opens, close it.

Step 3:

Open Seas0nPass and follow the instructions here http://support.firecore.com/entries/387605-jailbreaking-101-seas0npass to do the untethered 4.3 jailbreak.

That’s it. Very easy and straightforward. Once Seas0nPass is done doing the jailbreak, disconnect your apple tv 2 and proceed to do whatever you need to do with it (i.e. install xbmc and icefilms).

The line that you added to your hosts file will block apple from verifying the IOS firmware. Remember to go back in to your hosts file and remove the line you added so that iTunes can update like normal again.

I’ll try to keep an eye on this thread in case anyone has questions.

Man, You just saved my Christmas and with the easiest fix too 8)

Turnd out I had “another” IP for gs.apple.com in c:\windows\system32\drivers\etc\hosts (forgot to take a note of which IP).
Must have come from Seas0nPass or TinyUmbrella.

Oh - and by the way, it took me almost TWO weeks…

No such luck here.

I have a new unit of ATV2 with 4.3 firmware and would like to Jailbreak it without upgrading the firmware.

Is this at all possible?

If your already on FW 4.3 then jailbreaking will be no problem, download seas0npass and follow the instructions. I’m running 4.3 untethered currently with no issues. Hopefully 4.4.4 untethered will be out soon :slight_smile:


Good luck, let us know if you were successful.


Are you saying I just proceed with Seas0npass without pointing it to any firmware and Seas0npass will just jailbreak it?


Yes, if you are already on 4.3, just download season pass and follow the instructions to put the device in DFU mode and season pass will do the rest. Good luck. Let us know if you need any help.

Glad to hear this helped someone else out. Merry Christmas!

Oh no.

I am on recovery mode and cant seem to get out of it.



All good now.

Downloaded the latest seas0npass. Edit hosts file. Reboot MAC. POWERED the AVT2 while JB and does its job until final stage where I had to turn off POWER. All good

I get an 3194 error on the restore process.

I have installed the last version of iTunes and Seas0npass.

just close itunes and restart and do the process over.  It usually works.  Let me know if that doesnt work.  I have other fixes I can help you with.

Restart the computer and make sure iTunes is NOT open when you start the jailbreak. If it opens automatically when you connect the atv, close it and then start the jailbreak.

I connect the atv first, close iTunes, edit the hosts file, open seas0npass and start the jailbreak. Follow those steps and it should work.

So This should work for ATV2 4.4.4 Out The Box As well?


The hash is a comment in the hosts file so the line you suggest adding will have no effect whatsoever.

You’re wrong. Try it and see before commenting. I tried to restore in iTunes and downgrade to 4.3 from 4.4 first without editing the hosts file and got an error that the ATV could not be restored. After adding the IP with the hash tag to the hosts file, it restored in iTunes and downgraded to 4.3 with no problem.

I know that when you are coding a website in html, php, css, whatever, a hashtag will null out that line of code because it views it as a comment line. I think the hash tag has a different function when added to the hosts file. It worked for me. It has worked for others that have commented on this thread. I’m going to trust in the direct result I have seen and experienced for myself rather than doubt it and not even try and say it doesn’t work.

I used this on 2 ATV2s right out of the box. Worked on both.

I understand where dingemansje is coming from… editing the hosts file and putting the # in front basically comments out the line.  To prove, ping gs.apple.com with and without the hash tag there, you’ll get two different responses.  So, by all “normal” understanding of how the hosts file works, what you are proposing will do nothing.  

That being said, I tried it… and apparently (surprise) Apple / iTunes is not normal.  I can’t explain it, but I believe iTunes is manually reading the hosts file and somehow the # tag confuses it into working.  I just did a 4.4 downgrade with no issues after trying it a few times without the hash tag and getting an error saying the device wouldn’t support the firmware.

I did this on a Mac, haven’t tried on a PC so the behaviour might be different.

Based on what I see, the IP Address you enter shouldn’t even matter…

Either way, thanks for the hack…  i have 4.3 on mine now and am headed towards the XBMC install.

Merry Christmas! :slight_smile:  

Now, I have success. :slight_smile:

I had installed 4.4.2 with seas0npass tethered. Then, I did regular restore with iTunes.

After that, I followed the steps of the first post and success.

I used last version of iTunes and seas0npass on Windows XP.

Thanks guys. Raym you rocks. :wink:

I understood exactly what he was saying too. I don’t get why it works either, i was just trying to say that it works and that’s all that should matter. The gentleman that was saying it doesn’t work obviously didn’t try it. In theory it shouldn’t work, but it does. So while we, that have tried it, are enjoying our jail broken atvs, he is still trying to figure out how to downgrade instead of giving my suggestion a try.

Anyway, I have taken a lot of info from this forum that has helped me do a lot with my atv. The only thing I couldn’t figure out was how to downgrade firmware. After I figured it out, I thought I’d share how to do it because that info was lacking in this forum. I am so glad so many have done it and can now enjoy their jailbroken apple tv.

Merry christmas!

Well if it is the case that iTunes is manually reading the file then I will hold my hands up and stand corrected however if that is the case then it’s absolutely absurd of Apple to do so! A hash tag denotes a comment in the hosts file and there is no reason why a user wouldn’t have all sorts of stuff commented out in there.

No hard feelings by the way, I wasn’t trying to be an arse with anyone and I appreciate the help that is given on here - I was just commenting on how the hosts file is designed to work - in fact no application should ever even have to read it directly to use it, that is all taken care of by Windows.


Merry christmas anyway! :slight_smile:

  Raym   I don’t  know how the heck you came up with this, but man you are my Hero! It worked perfect. Thanks so much for taking the time to share this with all of us.

I wish I could buy you some beer because man you deserve it!