E: Type '.deb' is not known on line 1 in source list /etc/apt/sources.list.d/xbmc.list

when i try to install anything from maintenance it gives me this message "E: Type '.deb' is not known on line 1 in source list /etc/apt/sources.list.d/xbmc.list" please help

Same issue.  I am trying to run the commands to install XBMC on my Jailbroke ATV2 as listed in the XBMC ATV2 wiki.  Really would appreciate some advice on how to install XBMC now and how to get around this terminal error.  Is this error happening because SeasonPass did the jailbreak?

Damn this jailbreak deal is a pain in the arse!  You gotta be persistent as hell and just keep firing until you get through it.  Pertaining to this issue here is what I did to resolve the above mentioned error:

Logged in using WinSCP

Changed directories to the path listed in the error

After much trial and error and finding some similar but unrelated post regarding jailbreakin with SeasonPass removed the .deb in the xbmc.list file and replaced with #echo

You should then be able to proceed with the steps listed in the xbmc wiki on how to install on ATV2.  The whole jailbreak process would be so much easier if there were a clear instructional guide along with troubleshooting tips for common pitfalls.  For instance, I also received the 1602 error after updating with the seasonpass .ipsw file that others have had as posted in other threads on this forum.  After searching I finally found the thread explaining to try the ATV2 despite the error and found that it was indeed jailbroken.  What a long and sordid path this jailbreak debacle is on your first try.  Hope this helps you in some way should you encounter this issue.

The XBMC wiki instructions are a bit outdated, as all versions of Seas0nPass (except the very first version) have included the necessary repo additions for XBMC.

You can easily fix this issue by re-jailbreaking with Seas0nPass, or by modifying the xbmc.list file as described above.

I wonder if the jailbreak process with SeasonPass didn’t install XBMC due to the 1602 error I encountered.  I tried this twice and got the same error.  If that is the case and anyone has advice on what may be the cause of this error I would greatly appreciate it.  I plan on JBing another ATV2 soon and it would help make the process that much easier.  Thanks for the reply James.

I’m getting this same error, after an error-free installation of seas0npass.  Can navigating the filesystem on the appleTV, but as soon as I try apt-get update, I get the deb is not known error message.

Did you attempt to add the XBMC source manually?

If so, re-jailbreaking with Seas0nPass is probably the easiest way to cure the issue.

I used Seas0npass ;^)

I ran through the jailbreak process again, and everything works great now :smiley:

 

Thanks!