E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

 

Hi everybody, I have just jailbraked with pwnage tool (atv 4.2.1).

 

but error message always appears when I try to install PLEX, XBMC, etc. (on TV screen install from atv or even from imac running commads above):

 

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. 

 

 

what should I do ???

 

best regards.

 

Eduardo.

I am having exactly the same problem. Anyone have a fix?

I'm having the same problem too... quite frustrating!

I am also having the same problem, are there any solutions so far???

Thanks in Advance...

me too on latest fresh jailbreak using latest seas0npass / atv flash (black) and ios

Same here. Brand new Apple TV, Jailbreak went fine ad now this.

fixed it.

 

SSH in and follow this

 

http://forum.xbmc.org/showpost.php?p=766977&postcount=22

 

After the second command you wll get an error saying run 'dpkg --configure -a'

so enter it

then continue and the ATV will reboot and xmbc will be there :D

Delete all the files in   /var/lib/dpkg/updates  and try again !! :slight_smile:

Thanks Dalank your waay is works

Delete all the files in /var/lib/dpkg/updates and try again !! :slight_smile:

 

In case this happens again, simply re-running the aTV Flash (black) installer from a Mac or PC should fix this issue as well.

Hi James I don’t know how to configure or delete files or re-run atv on my compt.  I lost xbmc when i updated nito on atv2 (rookie mistake I don’t even know what nito is but my xbmc was running sooo slow I thought I’d try something)

so then I tried to re-jailbreak my atv2 5.0.2 and it did not work, then I googled and found I could retrieve xbmc in nito but i get the “manually run dpkg–configure’’ to correct problem”  

I don’t know how to even begin what you said to do

Help!!!

The best way to cure dpkg related issues is to just re-run the aTV Flash (black) installer.

sorry I didn’t have an aTV Flash before so I did not understand what it was, googled it and bought it from your site, just finished installation and about to check … 

Wow worked on this for three hours, was able to get infuse to install tried to install XBMC said it installed,but no icon went into maintenance and it said updat tried to update several times would not update. I then tried to reload atv flash same issue. I then rejailbroke and staryed form scratch, same result, I then ssh into ATV 2 would not load there, I then loaded Nito tv and tried to install from there no luck. When I first got ATV flash I had no issue installing this, I reinstalled everything because I was having streaming issues with youtube, which youtube works fine now just no XBMC. It seems the only suggestion from the people of firec0re is to reload ATV flash, Well I can tell you that does not work. I am running 5.2 untethered.

 

Hi
I have the same problem after installing Xbmc is showing update and Xbmc icon is not there
Could somebody help me what commend i should use to fix it as I’m not good with ssh
I tried re-run atv flash and then reinstall xbmc and it show me installation finish but xbmc is still not there and when I’m going in maintenance it show update
Please help
I’m running on 5.3

thank you! This helped me, xbmc is there now.

this works

 

This worked for me as well. Thanks James.

Thanks, fixed my XBMC update. So simple, didn't lose anything, did it right over the network without unplugging anything.

The suggestion from James also worked for me. I was trying to update xbmc from maintenance but kept getting that message. Then I reinstalled atv flash black and xbmc updated to 13.2.