Dynamic range compression/muffled sound with Airpods Max and spatial audio

Hello everyone,
I just tested Spatial Audio in Infuse with a new pair of Airpods Max.
Surround effect works, but, unfortunately there is clearly dynamic range compression always on no matter how the Apple TV is configured. The gunshots, explosions and everything that should sound big, is muffled and lower in volume than the dialog. Especially in headphones it is very annoying.
In comparison, same movie, through Plex, with old player setting on, sounds more balanced.
All the options like “reduce loud sounds” are off everywhere.
I hope you can look into this.
Thank you.

2 Likes

So, i did more digging. After a couple of more movies watched with Spatial Audio in both Infuse and Plex, i still believe there is a problem with audio rendering of surround sound through Spatial Audio in Infuse.
At the start of the movie, Infuse for some reason sounds much louder that normal, making a volume adjustment mandatory. Then as the movie progresses and action or just music is happening gradually lowers the volume, until everything, including the dialog, sounds very low, requiring another volume adjustment. There is still fluctuation of volume even after it is mostly stabilised, depending of what shows up on the screen.
Plex on the other hand starts at a volume level and stays at that volume level the whole movie. All the dialog has an equal loudness from start to finish and from what i can hear doesn’t seem to fluctuate the volume in action scenes versus the quiet scenes.

What are some examples of content that make the differences between Plex and Infuse very apparent? I’d like to do some comparisons myself.

The bigger issue is that some movies have an optional dynamic range compression curve embedded in the sountrack like the movie that started this thread. I am not sure if i am allowed to name the movie, according with this forum guidelines, but it is a Netflix exclusive release to my knowledge, and the soundtrack is an Enhanced AC3 with Joint Object (Dolby Digital Plus with Dolby Atmos) 768kbps format, which sounds awful through Infuse, and a little better though Plex. The DRC is so severe that makes it unwatchable.
I know it has a DRC curve because i transcoded the movie in Handbrake to a version with a plain AC3 sountrack.
Now the same movie with just AC3 5.1 in Plex sounds perfect, as it should sound, better than before, and much much better in Infuse, although as i mentioned in previous post, Infuse still has some issues that impact any movie.
Infuse should completely ingore any DRC curves when it decodes the soundtrack, right?
If someone really needs it, the “reduce loud sounds” option in AppleTV settings should cater to that, no?

Any movie in my experience starts louder in Infuse than Plex in the beggining then throttles the volume lower an lower. For example Transformers Dark of the Moon is all over the place in Infuse. And ive detailed in the next post some movies are even worse. That movie is 6 Underground.

I just tried to watch the same video using the Computers app (which seems to me a better baseline than Plex) and Infuse.
Thé sound of the video is 5.1 and I am using AirPods Max.

I could not hear an obvious difference between the two.

a, ok, i didn’t even considered computers app. i’ll give it a go for reference. but i suppose it only works with dolby and aac soundtracks, not dts, no?
what movie have you tried to compare?

Yes you’re right. No DTS in the Computers app. (IFlicks can convert it to AC3 though).
I used a TV show episode with Dolby DIgital + (E-AC3) audio.

Just did a test with Dark of the Moon and there definitely does seem to be a difference between how it sounds with Infuse vs Plex. It’s apparent pretty quickly. The aircraft flying around the 1 minute mark is a good example.

I don’t know if it’s worth noting, but I see the Plex old player converts the 7.1 TrueHD audio to 5.1 AAC.

It is a casual ‘people talking’ tv show episode the dynamic range compression, if it is active, is very hard to spot tbh. It needs to an blockbuster type of movie, with explosions, gunshots and loud music to be able to easily spot the volume changes compared to the dialog.

I haven’t used Plex on ATV for quite awhile and am not sure how the player usually handles certain audio. I actually was strictly a Shield TV user until spatial audio drew me back to ATV and Infuse.

I had read something about using certain xml profiles to get spatial audio to work with Plex, but it seems fine without. Do you happen to be using them?

Yes, plex doesnt direct stream dts on atv. Still sounds more “correct” than Infuse which direct stream and makes the decoding himself.
But in my experience the conversion to aac, on a bluetooth connection like we use with Airpods, it is pretty “transparent” sound quality wise. Also, the worst experience so far for me, the “6 Underground” movie, is a Dolby variety which is direct streamed both by plex and infuse.
Both apps benefit from recoding the soundtrack to plain dolby 5.1 whithout drc in Handbrake if the track had a drc curve embedded in the track from production, as i stated before.

No, i am not sure what you refer to. Default with Plex you get just stereo in Airpods. But has a “use old player” setting in the atv app. If you set that on, you get spatial audio multichannel even with dolby atmos compatbility.

Just curious, I don’t have any way to try spatial audio but have you done the pull down menu when playing a video in Infuse to see if first, there may be multiple audio tracks and second, if there are multiple audio tracks do you have the correct one selected (IE 5.1 selected instead of 2.0)?

It just sounds like many users are getting good results with spatial audio in Infuse so was trying to figure out what may be the differences. :wink:

Okay, it seems people were tweaking Plex player profiles to get spatial audio to work with Plex in iOS. This would have been before spatial audio was possible in the tvOS 15 beta this summer. I saw some people were still referring to it over the summer even though it looks like it’s not needed at all for the Apple TV and tvOS. Below is the link that talks about it.

I can confirm that’s not the case with me. I monitor what my Plex server is doing with a third party app called Tautulli. I use this to see whether things are direct streaming, transcoding, etc. In both instances the TrueHD/Atmos track is playing and it’s leading to different results. Besides, if you were playing a stereo track you would also see ‘spatial stereo’ instead of ‘multichannel’.

No, it is not the case. All the tests were done with surround sountracks. And i know how my movies should sound because i own full 5.1 surround speaker system.
I don’t want to down on anyone, but the reality is many users are trying Spatial Audio and like it, but their only experience with movie sound in home, is maybe at most with a soundbar, or they only watch normal casual movies where everything i discovered doesnt really make or break the experience.

Just wanted to check. Many users have 5.1 systems but don’t realize that in Infuse it could be selecting the 2.0 track by default and could cause problems.

Sorry to interrupt. :slight_smile:

Have you tired installing the latest AirPods firmware released yesterday to see if that makes a difference?

This wasn’t something which got flagged during our testing (and we haven’t been seeing widespread reports), so I’d like to gather more info here.

Do you have a sample that can be played in both the Computers app (or TV app on iOS) and in Infuse? Using that to compare would eliminate a lot of variables.

Something with AC3 or AAC audio should work. Maybe one of these?

https://developer.dolby.com/tools-media/sample-media/video-streams/hd-video-streams/

Thank you James for looking in to this.

I checked and i am on the latest firmware, but i don’t know when exactly it installed itself.

I looked into those Dolby samples you also linked and they reveal that the surround positioning is simulated very good in Apple implementation, but they are not good candidates for dynamic range compression.

I can definetely prepare some short samples tommorow. What is the prefered way to send them to you?

And i was unable to check the Computers app, as tvos15 can do home sharing only from Catalina and higher. My mac has only Mojave.