DVD VOB file playback hit and miss

I’ve just updated my ATV2 with iOS 4.3 and then successfully re-jailbroke the ATV and reinstalled ATV Flash. 


My reason for reinstalling it is that on three of the backed up DVD’s on my NAS, they don’t play back properly. One just displays the trailers menu and I can’t navigate off that screen and pressing the menu button simply returns me to the list of files on the NAS folder. Two others, both MGM DVD’s, either play without being able to pull up the DVD menu or just loop the MGM splash trailer over and over again. Again, pressing the menu button doesn’t trigger the DVD menu, just returns me to the MAS file list.


I’ve used DVD Decrypter to back all of these above titles. I backed up Flesh and Blood (also an MGM DVD) using it and after some aspect issues, a previous update to media player cleared that up.


Should I be using another DVD ripping program? 

Is this issue occurring with all your DVDs, or just a few?

If you’re able to provide the titles (and UPCs if possible) or the affected DVDs we can try and replicate the issue here.


Hi James,

only some of the ripped DVD’s are affected. 


Titles affected:

Dominion Tank Police (UPC: 719987233829)

Delta Force (UK) (UPC: 5050070003307)

Invasion USA (UK) (UPC:5050070023091)


I’ve tried others and they run fine. Both older DVD’s in terms of when they were pressed and newer ones too.

Thanks - we’ll see what we can do to get Chuck Norris back on the big screen.  :wink:


Thanks, James!


Hi, James. Just a quick update.


I re-encoded the VOB files using a different computer and they worked. Crisis averted. 8) Chuck Norris ahoy!