DVD playback in Media Player

James, you said:

We have a few hundred DVD titles here (created with various tools in both VIDEO_TS and ISO format) and out of that group only have 2-3 that show errors like this (in fact these titles are not playable in VLC on a Mac/PC either).

FYI, my DVD rip works perfectly fine with VLC in Mac and Windows. Since you also said only few is having this issue - unfortunately I’m one of them. I am very much willing to switch to a ripping tool that works just please don’t tell me to reencode the DVD because that works no doubt about that. Let me know. Thank you!

We love RipIt - that’s actually our preferred tool. :)

Are you streaming these DVDs from your Mac? Are you streaming via AFP or SMB?

Thats is good to hear James.

I can use AFP or CIFS or SMB, but it is not working, when I play a DVD i just get Loading and the spinning wheel. This is new though, v 0.9.1 i get blank screen.

Ok - are you streaming from a Mac or an NAS?

James, just like I said if you read my previous post I am connecting my ATV2 to a NAS running on FreeNAS 8.0.2 with AFP/CIFS protocol. ATV2 can read the files and folder and provides metadata of all the Video DVD rip I have except playing it.

Thanks!

Jame, FYI, I just tried streaming it from my desktop MAC using AFP, I get the same problem “Loading with spinning wheel” and nothing happens. So I guess it’s not my NAS.

Thanks!

Same with me, I’m getting the spinning wheel from my iMac.

I was fine until RC1. Auto MetaData fetching destroys the playability of the files.

if i play off of an iMac with AFP or with my WD MyBookLive NAS it will no longer play the DVD once I allow it to Fetch MetaData. Afterwards each file it is allowed to update the metadata of, will no longer play again, ever, displaying the message "!Playback error, An error occurred loading this content’ . If I try to play the movie in a folder that I do not give it time to fetch the metadaa it is fine. I tried deleting the preview jpeg but that does not help. FYI have have movies ripped via RipIt as well as Mactheripper and there is no difference.

Files that no longer play on the AppleTv continue to play fine on the DVD player app on OSX.

Trying some tests, disabled auto fetch set to View Type List  ‘Clear All Metadata’ still no go.

And I have never gotten 5.1 audio on DVD’s to work no matter what I try. Just a loud pop on the stereo when I play something. Have to use 2 channel audio only.

Apple TV Software: 4.3 (2557)
aTv Flash (black) RC1

Maintenance 0.8-1

I figured out what happened with my problem playing back media off of AFP servers. For some reason when the media fetch occurred it altered the permission(s) of the folders it touched. Not sure why, but was able to correct on the server end and now all is well again.

 

This is still a problem for me. Any news?

some interesting observations I’ve had with RC1 and dvd rips using RipIt

 

  • all rips show de-interlacing problems during playback.

  • one dvd starts at the main menu, the audio stops after the menu cycles  back to beginning of the title; this occurs on sub-menus as well and sometimes video stops too.

  • a couple dvd rips will not start at the main menu when loaded; they start at a sub-menu; also, NO audio is played on the menus

  • very rarely, i’ll have it tell me it is buffering then display an error streaming (forget the exact error message)

in general, playback works fine once i start the main feature (or episode)

note that these are all ripped to a .dvdmedia bundle

 

Has any one managed to solve this? I have the same problem, when I try to play ISO files the Apple TV hangs a while with spinning wheel, then restarts. I have latest version of AppleTV firmware, aTV flash and the media player.

 

Spinning wheel, loading and Then nothing. Streaming vob files ripped with DVD shrink from my synology 410. Works fine on my 1st gen apple tv but has so far to work on 2nd gen apple tv… Updated to latest 1.0 software which did not help. Please provide a fix;-)

Workds fine for me on the vast majoirty of my wripped DVD’s - so I do not think that there is an inherrent problem in Media Player that stops this working.   One thing that I have found CAN causes an issue is if your network is not up to it - I run a wired network as the WiFi seemed to struggle to handle the data rate.

Having said that you should be submitting a bug report with the appropriate diagnostic information so that FireCore can try and work out what is the problem on your particular setup.

Yep your right I will submit a ticket, but I am running a cabled gigabit network with a four bay nas reading @ 100mb/s so that is definitely not the problem;-)

@itimpi, congratulations it works in your setup! But the ratio of people saying it is not is like 20:1 so you decide. Anyways, can you do us a favor? It would be nice if you elaborate what your setup like. Are you using NAS? What NAS? What protocol are you using, AFP or SMB? Yes you are wired but if I do this I can’t no longer use iPhone for Airplay, but I can recheck that. What else?

I think the ration of success to failure is much higher than you think - it is just that you only tend to see on the forum those who have problems. I know of about 5 friends who have ATV2’s and they are all using the FireCore software without issues.

I am using a variety of devices to serve Media:

  • Drobo-FS NAS via AFP
  • Several Buffalo TeraStations via SMB
  • Netgear Router acting as a NAS for attached USB drive via SMB
  • Windows 7 PC’s via SMB
    These all work without issues. The one thing I do not have as standard in my setup is a Mac, but I have been using my ATV2 showing media from a friends Mac running Lion and connected via AFP (wirelessly).

I have found that I can use my systems either Wired or Wirelessly. I find that via WiFi there is tendency to get a ‘buffering’ message in MediaPlayer for higher bit rate video ouces. Instead I am using wired connection using Homeplug connectors (Ethernet over mains) as that seem to handle the higher bit rate video sources better.

In terms of media I have no problems with:

  • TV shows in AVI (XviD) format (normally 480p resolution or lower).
  • TV shows in 720p mkv format.
  • DVD’s ripped into VIDEO_TS format
  • DVDs ripped as .iso files. I normally just use the Copy facility in AnyDVD on Windows to create these.
  • Music in mp3 format
    I do have problems with:
  • Occasional ripped DVD’s (maybe 1 in 50). However since in most cases these ripped DVDs have problems playing on my PC systems I think they have issues from the rip process.
  • Video in .TS format - but this I expect as the bit rate is too high for the ATV2 to handle
  • Video from some video cameras until the video has been processed to reduce the frame rate to something sensible.

I do not doubt that people are having problems, but the fact that so much works for me suggests that they should be resolvable. I DID submit diagnostic reports in the early days of Media Player which may be why virtually all issues with my setup have all been resolved by the latest Media Player releases.

Still no dice for me on the latest build. Any Ideas? Tried copying to my Mac HDD with and without .dvdmedia extension. I know the devs like to use rippit and that’s what I’m using, but I might try something different just to rule it out as the issue. Anyone got any preferences?

 

Also, of the people having issues do any of you use a QNAP NAS?

Hi. I have been unable to play my DVDs ripped with DVD schrink. Running a synology ds410 on a wired gigabit network. Same setup works fine with my first gen apple tv. I finally found a solution that works, setup smb share instead of the default afp, vola it now works for me! However not running as smooth as on my first gen apple tv. Give it a go if you haven’t already. Cheers