DVD playback in Media Player

Hi Chaps,

I am having some trouble with playback of DVD rips, made using Ripit, in Media Player. I have tried with and without the .dvdmedia file extension and the results are the same, I get the following playback error:

“An error occurred loading this content”.

All of my media is in the same folder, on a QNAP NAS, connected via ethernet. Other media is working correctly (.mkv, .mp4 etc). First and foremost, I guess I should be asking, should this even work? I would really like to be able to view all of my backed up DVDs from my ATV2 Media Player, from reading other posts it looks as though it is supported, but maybe I’m missing something.

Some additional Information:

Apple TV Software: 4.3 (2557)
aTv Flash (black) Beta 7
Maintenance up to date (0.7-72) as is Media Player (0.8-144748)

I have also submitted my diagnostic info. Great product on the whole I am very pleased, but would be extra happy if this feature was working.

Thanks,
Tom 

 

Anyone? Please help!

If you’re able to send in a bug report we can try and track down what’s going on.

Thanks James. 

#19974

Hey guys,

Any news on this?

Thanks,

Tom

See Meta data but have same error as listed above when I hit play.  The files work fine on my mac.

I have exactly the same issue as well. I just updated to the latest version but the same issue. FC Team can you fix this please. Thanks!

Hi, 

I have updated today to 0.9, issue persists only now the file appears to buffer and then the Apple TV re-launches. At least the error is gone! Re-submitted my diagnostic info.

Thanks,
Tom 

 

Edit: Same if I remove the .dvdmedia extension.

Has anyone had a chance to look at this further?

I have updated to 0.9.1 today and the issue persists. 

ditto same as all above …have tried reloading and same error…works in xmbc but with lag…???

Anyone…?

Today’s Media Player update (0.9.2) has a few fixes for various DVD related issues (mostly related to loading certain DVD menus). Can you try updating and let us know if the issue persists?

Hi James,

No dice, I’m afraid. I have also tried with .iso’s/with and without the .dvdmedia extension etc and the issue persists.

I’ve also tried bypassing my Gigabit switch just incase, but its the same.

Tom

Are you streaming via AFP or SMB? Would you mind sending in new logs from your AppleTV?

SMB, I believe. Will double check and send in logs when I get home.

Yes, definitley SMB shares, re-submitted my Diagnostic Info. Thanks for continuing to look at the issue.

 

Tom

James, I’m having the same issue with the latest version of Media Player.

I just have one question that I don’t get why you guys keep on asking for diagnostic info, I think the best question would be did you use other jailbraiking tool aside from firecore or what protocol as you using to access your video files? Sometimes I do think that you guys don’t have appletv to check if your software is working or not. In my case, this is the fist time I jailbreak my AppleTV and I choose Firecore because your ad  and instruction looks so clean and simple but until I use the software bum! frustration! I’m sorry James but I have not used your promised software since I bought it because it just does not work with DVDs, that’s the only reason why I bought it because I want to be able to view my DVD rips using ATV. XMBC is too heavy for ATV2 it works fine playing DVD rips but unstable. And one annoying part is you keep on sending email we have added new features in media player while you can’t make one feature work.

Sorry dude just frustrated, but I still hope you guys will find time fixing one issue at a time before adding more features and adding feature that doesn’t work.

The reason we ask for diagnostic reports is because they provide clues as to why a specific movie file is not working.

DVDs are tricky as there are a vast number of formats and backups tools available, so the best thing to do is send in your logs, and open a support ticket providing as much information as possible.

We have a few hundred DVD titles here (created with various tools in both VIDEO_TS and ISO format) and out of that group only have 2-3 that show errors like this (in fact these titles are not playable in VLC on a Mac/PC either).

We’d love to fix the issue you’re seeing, so if we can replicate it here or find out what’s causing it based on your logs we’ll do out best to track down what’s going on and resolve it.

James,

For sure you guys are doing your best. Let me know which ripping tools is working on Mac that I can use so it works with your software.

I am using Rip-it for Mac and using FreeNAS as my file server using CIFS to access movie rips.

I would love to get a list of your ripping tools for mac or windows that works with your media player, so pls post and also if can post a suggested how to make it work with using NAS system like freenas.

Waiting for your suggested tool! Thanks!