DTS-MA Distorted / Buzzing Audio

I’ve just started including high quality audio on my rips since switching to Infuse 5, anyway I’ve just had an issue with buzzing/distorted audio on the DTS-MA track on one Apple TV that’s connected to a stereo TV. Switching to the regular DTS track (that I luckily left) and it’s fine, switch back and distorted. Reboot fixed until I exited and re-started the movie.

Does anyone else have intermittent issues with DTS-MA?

I tried setting the Apple TV to audio output to ‘stereo’ and that didn’t fix it, seems like a software issue to me as the reboot fixed temporarily. Is Infuse crashing an audio service on the Apple TV when decoding high resolution audio?

Is Infuse’s Audio Output option set to Auto, or is it set to Passthrough?

Normally, a DTS-HD MA track will contain a DTS core track inside, so you would always have a fallback - though I’m not sure if there are tools out there that would allow you to modify this.

It’s set to auto, this issue just arose on the same film on the main TV where the Apple TV is connected to a soundbar.

What’s odd it on reboot it worked, so does seem to be a software issue. Movie is Ghostbusters (2016).

I note by buzzing I mean a fast clicking sound, sounds like a digital signal unprocessed.

In one of the first versions of Infuse (and maybe tvOS) DTS96/24 works ok and my amplituner received a proper signal (it displays DTS96/24).
For now it is impossible to achieve this:

  • when Infuse’s Audio Output is set to Auto then sound works, but is decoded by ATV and send to ample as Multichannel PCM,
  • when Infuse’s Audio Output is set to Passthrough only static noise is sent.

So I don’t know if a new version of tvOS screw things or new version of Infuse. Maybe you should try to perform some test with DTS96/24 or DTS-HD MA?

EDIT:
Or maybe I don’t remember exactly if it really ever worked with ATV4 :).
Because I have performed now fast test: I have connected my old ATV2 with Infuse - and DTS96/24 works fine. So maybe problem is in ATV4 hardware or tvOS, that it does not support passthrough DTS96/24 (or other hires audio formats)? So it looks that older ATV2 is better in this matter :(.

Apple TV supports LPCM and Dolby Digital only, DTS is decoded and sent via HDMI as lossless multichannel PCM. (Pretty sure of this).

I didn’t get any further feedback on my issue, do I need to send some logs? As a reboot fixes and it sometimes plays it seems to be a software issue, but as app force quit doesn’t fix it seems to be the Apple TV audio that is crashing.

So it looks that AppleTV 2 has better support for DTS because it supports sending it in bitstream.

There are two places where the audio output can be adjusted, and the combination of settings you are using will determine what kind of audio leaves your Apple TV.

A bit more info on how this works can be found here. Audio Options (tvOS) – Firecore