DTS/Dolby passthrough not working - Just (ugly) noise

I had the free trial expired, so I bought a 1 year Pro subscription from the ATV4K Settings (I don’t know if it matters). All movies that were playing fine with audio passthrough (either in DTS or AC 3/EAC3) now they show in the AVR as PCM 2.0. I didn’t change anything in the AVR.

If I use the “Auto” option I get PCM 5.1, but that’s not exactly why I paid for it. DTS works fine from Sony’s Video app on my TV via HDMI-ARC, showing as such in the AVR. I tried power cycling the ATV 4K, AVR and TV. No changes. What changed? I hope it hasn’t to do with the last tvOS 11.3.

A few things to check.

  1. Infuse’s Audio Output option set to Passthrough.
  2. Apple TV’s Settings > Video and Audio > Reduce Loud Sounds is turned off.

Hi James,
thanks for replying.

I have checked they both are like you asked. Again, I have tvOS 11.3 beta, if it matters. I am quite surprised because it was working just fine during the trial. Same tvOS settings, although it is true that the update automatically changed the range and frequency matching settings for videos to “No match” (but I went through them and restored my previous settings wherever I’ve found something different). Audio settings seem normal to me, though. The scratchy white noise, changing frequency depending on the track, is totally new.

Would it help if I uninstall and reinstall Infuse? Would it keep all my libraries, metadata and settings after reinstalling (I am used to stupid Android TV losing everything)?

Ok, there’s a good chance it’s related to the 11.3 beta.

In the past, Apple has broken passthrough in early betas, and then fixed in before the public release.

For now, if passthrough is important to you, you may be best served by switching back to tvOS 11.2.5.

Oh, is that possible to roll back to 11.2.5? Any idea how? Otherwise I’ll google it. Also to be sure it is the update that broke it.

Then I have a video with DD+ (EAC3), Audio passthrough is On in the main Infuse settings, and that plays (no white noise, to be clear). But in the audio options in the video player there is no passthrough settings, and the AVR shows it as PCM 5.1. Still it was like that during the trial as well, I mean, with Dolby in general (DD/DD+ and also DD TrueHD) always showed PCM. Any reason for it? It gets a bit confusing.

This guide has more information on the audio options available in Infuse.

FWIW, you’re not losing any quality by leaving Infuse set to Auto.

Yeah, I had read that document already. I was wondering why in “passthrough” mode Dolby never shows up in my AVR, while your article says it should.

But if you say the audio is exactly the same in “auto” I will be fine. It seems the Apple TV 4K can’t roll back from the beta anyway. I’m just one of those nerds that like to see which is the real audio format in the AVR… :wink:

Thanks.

I did some “blind” tests and couldn’t tell a difference at all. My wife couldn’t tell a difference either when she was on the other side of the test too. I’m ok just seeing PCM now.

Yes, I trust you guys. Also because I had read that the conversion from DTS/DD whatever to LPCM is supposed to be always lossless. But so at this point the passthrough option is only for “aesthetic” reasons?

Also, did anyone else tested the audio passthrough with tvOS 11.3 beta? That noise was a bit scary at first, to be honest.

Passthrough is the only option we had in Infuse when we originally released v4 on the Apple TV back in 2015. Since then, we added LPCM output which allows us to support the lossless formats like TrueHD and DTS-HD MA.

Passthrough is still useful in some cases, as there are certain devices that won’t support multi-channel LPCM. For example, if you are using ARC on your TV (or if you have an optical cable in any part of your wiring pipeline) you won’t be able to use more than 2 channels of LPCM, but you can get 6 channels of lossy AC3/DTS.

1 Like

Oh, you’re right! Since one of the reasons I bought the ATV 4K has been to deliver the audio straight to my (brand new) AVR with DTS-HD/Dolby TrueHD support I totally forgot about HDMI ARC/Optical! Which was a pain, especially on Bravia TVs. PCM 5.1 doesn’t passthrough indeed (well, nor DTS since it is broken). Also the audio passthrough from the apps on TV (like Kodi) is required to get the best audio (otherwise I get only stereo), while on Infuse on ATV it is the other way around, then.

Ok, it makes sense now, thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.