Dropped frames when playing back 24Hz 4k HDR content at 60Hz.

So I recently noticed something kind of odd. For whatever reason, when playing back 24Hz 4K HDR content on the Apple TV 4K through Infuse, with the Apple TV set to a 60Hz output, Infuse seems to drop a lot of frames, which results in very noticeable stuttering. I’m not referring to the judder that can sometimes be visible when playing back 24Hz content at 60Hz, but rather a very noticeable stutter in the picture that looks like dropped frames.

When playing back this same 24Hz content at 60Hz, but without “Match Dynamic Range” turned on, so it plays back in SDR instead, it plays back fine with none of this stutter at all in Infuse.

Furthermore, when playing back this same content in the Plex app instead, still with the output set to 60Hz, and with “Match Dynamic Range” turned on, they playback in HDR very smoothly as well, and since Plex uses the native Apple TV video player, I think the issue is with Infuse’s custom video player dropping frames.

The videos playback smoothly in Infuse w/ HDR if I turn on “Match Framerate” so they playback at 24Hz, but I don’t want to leave “Match Framerate” turned on for a different reason. There is a bug with the Apple TV 4K that causes 24Hz SDR content to have a noticeable flicker in dark scenes on my TV, so I would prefer to leave my Apple TV in 60Hz only mode, and rely on my TV to display the 24Hz content without judder from within the 60Hz signal, which it can do just fine.

Any idea why Infuse seems to be dropping these frames when in 4K HDR 60Hz?

Thanks!

TV Model: LG B7 OLED

Do you have trumotion enabled? I have the same TV sand have zero problems leaving match frame rate and match content turned on however I have trumotion turned off (it has to be right off. Setting it to zero causes problems).

I do have trumotion enabled, in user mode with both settings set to 0, but I don’t think that is causing this problem. Plex can playback these same 24Hz 4K HDR videos at 60Hz in Direct Play without the dropped frames that I am seeing in Infuse, so I don’t think it’s a TV setting related problem

Just did a few quick tests here on a C7, and found pretty good results with both RealCinema and TrueMotion disabled. Having RealCinema turned on with TrueMotion off seemed to be the worst, with obvious dropped frames. Also, there is some info to suggest TrueMotion needs to be set to at least 1 to avoid 3:2 judder on 1080p and 2160p sources. https://www.avforums.com/threads/lg-real-cinema-on-or-off.2004928/#post-25216520

FWIW, it’s hard to get a 1:1 comparison with Plex, as both PMS and Apple’s player can manipulate the stream in a variety of different ways. Infuse will always play videos in their full, unadulterated glory.

I will try turning RealCinema off when I get home and see if that helps. I tried setting de-judder to 1 within TruMotion earlier, and that didn’t seem to do anything. Rtings mentions that RealCinema needs to be turned on to display 24p content from 60p sources without judder though. (https://www.rtings.com/tv/reviews/lg/c7-oled under the 24p Judder section)

Thanks for looking into this!

Sounds great!

Another approach you can also try is to set noise reduction to low on your B7. This has been reported to resolve issues with dark scene flickering with SDR content, while providing virtually no impact on playback, and would allow you to re-enable frame rate matching on the Apple TV.

Yeah, I’ve tried setting noise reduction to low before, and it definitely significantly reduces it, but I can still notice the flickering from time to time. I have also noticed a minor impact on film grain with some of my blu-rays with noise reduction on low, which is why I’m not a huge fan of that method. Especially since I am running everything through my receiver first, so setting noise reduction to low will affect my blu-ray player (and all my other components) even though I am only using that setting to fix the issue with the apple tv. I really wish Apple would fix the issue with SDR 24p content, it’s my only real complaint with the unit.

I really appreciate all the help though!