Downgrading

Howdy,

I have been jainbreaking my ATV2’s for a long time. I waited too long to go from 5.0.2 to 5.2, and now I got stuck on 5.2.1 and Apple stopped signing 5.2.

I could not understand why Seas0nPass did the build and Itunes errored stating my device is not eligible. After 4 times failing, I then let Itunes update and restore. Then I saw it was at 5.2.1. Dah!

Just before I starting trying to update, I did a backup of the firmware in my maintenance menu. I saw that is said my blobs were save somewhere. I think it said 5.1 was the last one in the list.

Are my SHSH blobs stored somewhere? How do I get them so I can downgrade?

It has been several versions since I used TinyUmbrella, so I am not sure what version I have backup up locally, but it is most likely version 4.4

 

Thanks in advance for any help.

Regards,
Rick

 

 

This may help you. http://forum.firecore.com/topic/10083

Thanks AppleTVGuru,

 

I did see that tutorial already. However, when I did my backup from the maintenance menu, where did the blobs get saved to?

Did they go to Cydia or somewhere else? Will iFaith find those files automatically?

 

Thanks,
Rick

OK, so the answer to my question is my blobs were uploaded to Cydia from the backup function in the maintenance menu.

I found a Windows mach and ran iFaith. It was able to see all my blobs on Cydia, including 5.0.2,5.0r1, and 5.1

 

I will attempt to go down to 5.1.

OK, so the answer to my question is my blobs were uploaded to Cydia from the backup function in the maintenance menu.

I found a Windows mach and ran iFaith. It was able to see all my blobs on Cydia, including 5.0.2,5.0r1, and 5.1

 

I will attempt to go down to 5.1.

I am new to this atv2 and did a rookie mistake (smh).  I was trying to figure out a way on how to get add ons onto my atv2, and accidentally restored my atv2.  NOW, I’m lost because I am trying to get seasONpass, but I began to come across forums on how apple stopped “signing.”  Is their a way I can get the latest version (before apple stopped signing)?  Will the newer version get jb?  I just received this product (ebay)  LAST PHUCKING NIGHT!..smh

http://forum.firecore.com/topic/10083

Hi again, I am still having problems.

I was able to use iFaith 1.5.5 so it got me to 5.1 (from 5.2.1), but it did not seem jailbroken. I could see in the about screen that I have 5.1, but I could not ssh to it. Connection refused when ssh to it with root.  ATV flash black said that it was not jailbroke.

If I use iFaith, how do I get flash installed again?

 

It seems good that I can successfully get to to 5.1, but I really cannot see what iFaith is injecting. There are no things I can set.

I tried to use Sn0wbreeze as well. Same result when I choose simple mode.

 

Thanks,
Rick

 

After a bit of reading, it seems that I have to use iFaith to stitch the blobs. Fine. I am doing that. I have my blobs from 5.0.2 and 5.1, and a bunch previous.

I have now tried with version 5.0.2 and I can see that 5.0.2 is what I am on in settings/general/about.

I am unable to SSH to my IP using root. ATV Flash Black is unable to detect my ATV as jailbroke.

I have done this a lot without any problems before. I know that 5.x has changed things. What the heck is iFaith doing, if it does not inject Cydia, SSH and whatever else is needed to install things?

 

Can someone recommend how to get the jailbreak back in?

 

Thanks,
Rick

appletvguru, thanks for the link, but I have a question.  The steps in the link seems like it is for pc, would the same steps work for the mac that I am using?  Is their a difference?

Ok, after two days and about 30 attempts, I finally solved this.

Here is is what worked for me to get the jailbreak back in:

I made sure my hosts file was clear of any apple entries.

I used Sn0breeze v2.9.13 with 5.1 SHSH. I chose the iFaith option.

My ATV2 will not go into DFU mode with out a power cable. The blinks are just slow and it never kicks it into DFU without power.I have tried on my iMac and my HP laptop running Win7. So a power cable is attached as well as my micro USB.

iReb kicked it into DFU, then I used iTunes with the shift key held to use the signed 5.1 ipsw.

When I started the ATV2 up on the TV, I could then see Nito was installed, and jailbroke.

I could then use ATV Flash Black to install the maintenance menu and get XBMC and other things back in.

 

I still do not understand why iFaith could not do this. Also, I do not understand why sn0wbreeze did not work in simple mode.

 

One note, itunes always takes forever, doe not stop restoring, and actually comes with an unknown error when I unplug the ATV2. The last error I got was (0xE80000065).

 

Hopefully, this helps someone else who is stuck like I was.

I have been jailbreaking  and updating around 15 ATV2’s over the past year for family and friends. This time it was a real challenge.

 

Thanks,
Rick