Downgrading from 5.2.1

So I just got an apple tv2, and apparently the person i got it from did an update and restore yesterday. Is it possible to downgrade the firmware to 5.2? I tried through iTunes but that did not work. 

i have the same problem.

apple tv 2 in 5.2. I tryied to restore using seas0npass in 5.1 or in 5.0.1 (because it’s the only version with saved shsh) and restauration in itunes went wrong; I get message like “couldn’t restore, this device is not compatible with requested version”

I tried with launching tinyumbrella and the tss server, but then i get error 11 from itunes.

I tryed to restore using redsnow 0.9.15.b3 too, but i get an error during “uploading iBSS” stage telling “couldn’t find recovery mode device” 

can somebody help me?

Let me know if there is an answer to this. Im having the same problem. I used to SeasonPass to try to downgrade to a couple different iOS versions and get an error.

You can only downgrade through SeasonPass now that Apple is no longer signing earlier release if you already have the save shsh blobs for the target release for your device.

I too am having the same problem.  I picked up a used ATV2 and it was already updated to 5.2.1.  Any help would be very appreciated.  Do I (we), just wait for a new SeasOnPass?  How does it work? 

I am afraid that you have no other choice!

We can only hope that a jailbreak for this new firmware does not take too long to materialise.

i finaly manage to downgrade

i do this on windows

my apple tv was in 5.2 stock, so i wasn’t able to jailbreak using firecore because apple is no signing anymore 5.2

so i retrive my shsh 5.1 previously saved on cydia, thanks to tinyumbrella

then i build custom fireware using snowbreze.

so at this step, i had a custom firmware in 5.1 with my shsh in it.

then i try to restore with itunes but it failed. it was freezing on stage “checking apple tv firmware”

so i added an entry to my host file (to, then put my apple tv in correct DFU mode, using ifaith

and then i successfully downgrade my apple tv , using restore in itune (with choosing my custom firmware)


i previously try with firecore, ifaith redsnow and tinyumbrella (tss server) but i always had error when restoring in itunes (3194,1600,11)

hope it will works on others apple tv, hope it could help some people


Wow!  That is very advanced.  I do not have a previously saved shsh (I think).  And sorry for my ignorance, but the rest of what you did also eludes (scares) me.
I guess I just have to wait.

it’s not so hard to do as it seems :wink:

first of all, you have to be sure if you have any shsh just check.

if you have already jailbreak your apple tv once, it may have been done automatically

try to launch tinyumbrella. plug your apple tv on your computer, then you should see your device on the list on the left, then click save shsh.

if the list in the middle get’s not empty, it means that you have shsh saved (retrived from cydia server)

i you never jailbreak it, i don’t see any way for a shsh to be saved ->you have to wait and pray for jailbreak of 5.2.1

I have not jailbroken this particular ATV, but I do have another unit that is perfectly jailbroken.  Can i use that one to get what I need?  If you think I can, please be as detailed as possible.

Unfortunately not. The shsh blobs that would be required are device specific.

Thanks.  I will be patient.

what did you add to youre host file because i am stuck too on checking firmware

i added the following entry in my host file :

Sorry Mate, unless you have restored an apple tv 2 previously you will have to just sit and wait…Sucks!

I have a house party on Sunday, please please Firecore gods deliver a fix for 5.2.1 before then :slight_smile:

I was able to downgrade and do a tethered jailbreak on my apple tv2. Here’s the step by step guide

Apple are still signing 5.3.
You should be able to do an untethered jailbreak directly from Seas0nPass.

Since you were replying to a post that is over 2 years old I very much doubt that the problems still is relevant :slight_smile: