downgrading from 5.0 to 4.4.4

Everytime I try to downgrade, it either still selects the 5.0 ipsw file or says I’m not allowed anymore. What gives?


Heres what happened. I tried to update through the Apple TV, but said that 4.4.4 was up to date. Obviously not. So I plugged my ATV into the computer and restored it. Which then updated it to 5.0. Then After fooling around with 5.0 I wanted to go back to 4.4.4. I open up Seas0nPass, select the 4.4.4 in the prefs, Click Tethered and it goes through the motions then at the very end says it can’t do it.  So now I’m stuck with 5.0 which I dont want.

new problem… i can JB into 5.0, but when I move the Apple TV to another TV or the Apple TV powers down. It gives me the connect to itunes… any ideas why?? Like I can get it to work on one TV and do what I want to do. Then I move it to another TV and I have to redo the whole process of JB again.  Anyone with ideas why???

The current jailbreak is a tethered jailbreak. This means that any time you lose power (or do a hard reset) you have to connect it to your PC/Mac via USB to complete the boot process.

You therefore need the PC/Mac to be located close to where you intend to use the ATV2 (or be using a Notebook).


k. but still doesn’t answer my question on why, I can’t downgrade to 4.4.4 with the 4.4.4 and 5.0 installers… 

Do you have saved blobs for the 4.4.4 release? If so you should be able to install the 4.4.4 firmware.


In SP ?? Yes, when I open up the prefs, it gives me 2 options. 4.4.4 and 5.0. I select 4.4.4 and it goes through the motions then at the end it says I can’t. 

Nevermind, figured it out. Didn’t realize that I had to Right Click to downgrade in SP. 

Sorry to ask a silly question but what are blobs and how do i know if i’ve saved them?  If i did not save them do I have any other options for downgrading to 4.4.4?

Blobs are the digital signatures for a particular release of firmware and are device specific. If you have not taken explicit action to save them then you will not have them. Without them you cannot downgrade.