Downgrade from 5.2.1 to 5.2 Success

Hi i have been on 4.4.3 since it came out with everything running great for which seems like forever but on 19th Marech my xbmc kept crashing several times which it has never done to this degree, i done reboot each time then the screen just went blue with flashing led, i tried to kick it out with tiny umbrella but it wouldnt recognize it, so i ended up updating to what i thought would be 5.2 but turned out it was 5.2.1, so i have all my shsh blobs saved but i have spent hours now trying to restore it with season pass, ifaith but i just get errors 3194, 1600, 1604, 1. im using itunes 10.7 three different pc’s all seem to be same result, question is am i right in thinking that i can downgrade from 5.2.1 as i have my shsh blobs saved?

I traded a new Apple TV3 on the 19th for an Apple TV2 and saved the SHSH signatures just before Apple stopped signing them.  I’m in the same boat as you now.  I haven’t been able to jailbreak, but I’ve been able to downgrade to stock firmware by building signed IPSW blobs with iFaith.  Is jailbreaking still possible? Please post if you find the solution.

What I find odd is that I was able to downgrade my iPad using ifaith, if anyone has successfully downgraded from 5.2.1 to 4.4.4 or 5.2 please let us know.

Below is my host file is there any thing wrong with that which could prevent the downgrade?

Copyright © 1993-2009 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual line. The IP address should

be placed in the first column followed by the corresponding host name.

The IP address and the host name should be separated by at least one

space.

Additionally, comments (such as these) may be inserted on individual

lines or following the machine name denoted by a ‘#’ symbol.

For example:

#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

localhost name resolution is handled within DNS itself.

#    127.0.0.1       localhost
#    ::1             localhost
#74.208.105.171 gs.apple.com
#74.208.10.249 gs.apple.com
#127.0.0.1 gs.apple.com

@Chrispx i see you downgraded, what version of itunes were you using and what were the host settings you used?

Right i finally got it to downgrade to 5.2 by deleting all apple details in host and using 74.208.10.249 gs.apple.com with no hash in front.

I just lost at least 8 hours of my life now on to jailbreak :slight_smile:

I used latest ifait I was able to downgrade my using shs blos saved… however I can’t jailbreak it

I’m glad you’ve had some success. I downgraded by stitching saved SHSH to stock 5.2 firmware with iFaith. I don’t think I had Tiny Umbrella running since iTunes sees a valid signature applied and allows the downgrade. The process completes and hangs on verifying, but it doesn’t make a difference at this point. When I disconnect and plug it into the TV, it shows 5.2. I used iTunes 10.7 on Windows 7 booted through Boot Camp. I was able to use Redsn0w to upload SHSH to Cydia. It gave me an unsuccessful message, but later Cydia had the SHSH signatures on file. This hasn’t helped me yet, but I thought it was important.

Please keep me posted if you can jailbreak. Neither Sn0wbreeze nor iFaith allows me to stitch the SHSH to the custom firmware created by Seas0npass. If modifying the host file works, I’ll try it next. Good luck.

that what happen to me why my first tried but later it work. if you got stuck at state prepare apple to for restore just exit out of itune rerun iReb to enter DFU mode.  After you are in dfu open itunes , press SHIFT +restore and navigate to file on your desktop that previously create by ifait…

 

i additon i’m trying using this method for ios 5.2 keep getting error (-1) not sure what is that but seem some thing odd… it went through whole process but last step got error (-1).  I’m gonna try it again today

might wanna look at this see if it help

im having problems jailbreaking too keep getting error 1601 & 1602.

Do you have the power cable plugged in while trying to jailbreak?  If so then 160x errors are not at all unusual as long as they happen at the end of the process.   Have you actually tried plugging the ATV2 into your TV to see if you are jailbroken despite getting the error.

Great news i finally jailbroke it again. used snowbreze with ifaith, also took the # away from host

So did you downgrade it to 5.2 or a prior version?

Any chance you can outline what you did from beginning to end so we can give it a shot? :slight_smile:

Yeah I downgraded from 5.2.1 to 5.2 then edited host file with 74.208.10.249 no hash in front, saved blobs with ifaith then used snowbreze to create ipsw then followed instructions into dfu then it done the rest. I now have nito tv and Xbmc installed :slight_smile:

 

Sorry new at this, but did you have shsh blob for 5.2? 

 

Any chance you could post a step by step? I foolishly updated to 5.2.1 by accident since my atv was misbehaving.

All the lines are NULL because of the hashes at the beginning of the lines. It’s an empty file

Hello, i want to know if they exist NOT to JB the 5.2.1 just to downgrade to 5.2 if can doit please let me know i have 1 weeks trying to downgrade on itunes and i get error 3194 and i use iFaith and Sn0wbreeze and Seas0npass and nothing to fix it, thanks.

Ok, can see your flow.

What I don’t see is how you used iFaith to save the blobs.  Assume they would have had to been already saved for 5.2 prior?

Meanwhile for me, as I had blobs for 5.0_9B179b, but when using sn0wbreeze, it only can verify 5.0_9B206f… so my blobs were useless with it. 

However I was able to pre-sign my older 5.0_9B179b IPSW with iFaith (which did recognize B179b), and install it back on the ATV2.  So I’m happy there.  Just not seeing how sn0wbreeze can create the ipsw when it needs original’s, doesn’t presign them, and then launched iTunes? 

Is the 74.208.10.249 default IP where iFaith stores the blobs?  Maybe that’s the trick?

Use your saved shsh and make a ipsw with snowbreze the only other change i made was i deleted all apple in host and just added 74.208.10.249 gs.apple.com with NO #. I did have many errors and failures but i kept at it switching between 2 cables and 2 computers but it finally worked. This was a downgrade from 5.2.1 to 5.2.

 

@ Mightyjew your right the # does mean null but i posted that when i was trying all different ways but me using 74.208.10.249 gs.apple.com  with no # got me down to 5.2 then enabled me to jailbreak with snowbreeze it may have been coincidence but i am just happy that it worked for me, it may or may not work for others but then i do find it odd how it wont work on one computer then it works on another its the same with cables as i see a lot of people find they have this problem. The answer is just persevere it has taken me the best part of my two days off.

that way it’s so important to have an atv flash installed because if you didn’t you. would only have been able to go back to 4.4.3 the atv flash does it automatically