Done it all and still doesn't work!

I’m consistently getting a 3451 error after doing everything James suggested.  First thought it was the USB wire, got a new one, that worked, then downloaded Seas0n Pass three times and noticed that all three are the same vintage, so that wasn’t the problem.  My AppleTv is current with the latest update.  I did try the tiny umbrella fix, to no avail!  I’m having two issues, one the seamless update after DFU mode doesn’t work, and when I try to do it manually I keep getting the 3154 error! I’m beginning to look like bugs bunny with steam coming out my ears! 



I meant a 3194 error not 3154.

See the attached link re: coded errors.  Sounds like either a version issue, or a host issue.


Yep, did the tiny umbrella trick, still no luck, my itunes, appletv, and Seas0n Pass are all very current, still don’t understand what I’m doing wrong.

I know it’s a long shot but you could try uninstalling iTunes - then re-install it and try again.

I tried updating to 4.3 iOS to get Vimeo (the only new thing on the UK version of the update but still worth having) and tried to pick up the Seas0nPass IPSW manually by using shift + restore. It didn’t work.

I downloaded the newest version of TinyUmbrella and unticked the Cydia server option. I then uninstalled iTunes, re-installed it and ran Seas0nPass again but this time choosing the automatic iTunes restore option. Voila! it worked. I don’t know if iTunes caches anything that screws up a restore but if I ever have to run Seas0nPass again I’ll use the iTunes uninstall/re-install procedure again.

I updated using Windows XP Pro.


Try this...

  1. From your Finder's 'Go' menu, select 'Go to Folder'.
  2. Enter: /etc/
  3. Open the 'hosts' file using your favorite text editor.
  4. If you see a line that includes '' that means you're using Cydia's servers, and not Apple's.

Removing that line manually, or unchecking the box in Tiny Umbrella (as described here: should resolve the issue.

I finally got it to work, by uninstalling Itunes (and yes the original itunes before installation was current) and then re-installing it.  What a pain in the ass, they sure didn’t make it easy as in the videos.

Glad you finally got it to work. As mentioned in my previous post, uninstalling then re-installing iTunes was the only way I could get it to work.

Patience is definitely a virtue when JB’ing the ATV2 and I’m sure the PITA factor will dissipate as you start to enjoy the fantastic extra features that aTV Flash black offers.

What was hilarious, ok so I get it to work, it’s finally jail broken (I nearly had tears in my eyes), and then I install play on so I can watch ESPN3 for college football, and then that didn’t work!  I was so pissed two hours fighting with that crap, come to find out it was a problem with ESPN and their revamp!  They finally got it to work, what an ordeal.  I do really appreciate your suggestion, this could have gone on for months!

I have tried it all; thats me as well except for uninstalling Itunes.

I tried the hosts suggestion. Did not have that line to remove. Mine looks like this:

Host Database

localhost is used to configure the loopback interface

when the system is booting.  Do not change this entry. localhost broadcasthost

::1             localhost 

fe80::1%lo0 localhost

I think ESPN3 is available as an addon for XBMC on the Apple TV. I don’t think you need to run it through PlayOn.

If you’ve tried it all except uninstalling and re-installing iTunes, then that’s what you should try next. It worked for me and davee.0199 - it could work for you. You won’t lose all your stored music.


Bummer because I just paid $40 for Play On, I wonder how you do that, and is it free?

I will give it a try tomorrow. Thanks.

Download the Repositories Installer - - copy the file to the Apple TV (I use WinSCP - don’t ask me how to use it, Google is your friend) then Go To System => Settings => Addons => install from zip, then browse to where you saved the Repo Installer  zip file.

After installing the Repo Installer, it will be available under Programs on the main menu. You can then install as many repos as you like - I’m not sure which one has ESPN3. You’re not finished yet, you need to then chose Videos from the main menu, then choose Addons, then Get More… ESPN3 should be available from the list of available addons if you have the correct repo installed (I think it’s bluecop’s repo but I’m not sure). Choose ESPN3 then choose Install. Easy - ish!

Please be aware that not all addons will work - some were written for older versions of XBMC and haven’t been updated but, the last time I checked, ESPN3 was OK.

Of course all of this will mean nothing if you haven’t installed XBMC for the Apple TV 2 and the easiest way to do this is by using ATV Flash black. Don’t worry if you haven’t, it’s very, very easy to install. Once you’ve installed ATV Flash black you can install XBMC from the Manage Extras menu.

And yes, XBMC is free but ATV Flash black must be paid for (although it is very cheap during this late beta phase).

Ok. I manually uninstalled ITunes. Then reinstalled from Apple website. Then ran SeasonPass. All went well and then at the very end got an error message. Shut down, rebooted. Reran Seasonpass. This took about 25-30 minutes to download and configure all the files and ISPW etc. (it used to take less than 10 minutes) Then it restored from Itunes with the positive final message, that the ATV2 is set to factory settings ( here meaning Jailbroken) Installed ATVFlashBlack after doing all the settings needed on the ATV. It is working. Only thing still missing is AC3 passthrough. Nothing gets that working. Perhaps any future Itunes updates should not be loaded through autoupdates but always manually downloaded? This was a long haul, but it worked.

I also trashed any other ISPW that Seasonpass built before using Seasonpass again.

On Apple TV’s audio settings change the audio output from “auto” to “16 bit”. I haven’t tried this myself yet (I don’t have any AC3 files at present) but I’ve read that it works for some people. Glad you finally got the jailbreak to work. The rewards are well worth the hassle.

That one has not worked for me in the past with any versions, But, since I just reinstalled everything, I’ll try it one more time.


I had that similar issue when I re-installed Itunes and then ran Seas0n pass, but if you hook up the ATV and try it, my guess is that it probably stuck and will have been jail broken.  It’s very stealth like.  Give it a shot.  


As for the guy / gal suggesting a cheap fix to score ESPN3, wow, that whole process you describe sounds very difficult especially to a guy like myself who is very nerd machine challenged.  But I really do appreciate the tips.