Dolby Vision, Version 1.0, dvhe.05.03, stuttering on Apple TV

I have problems playing the following format without stuttering on an apple tv 4k (Model A1842 - tvOs 16.5):

Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : iso2 (isom/iso2/dash/iso6/piff/dby1)
File size                                : 705 MiB
Duration                                 : 59 min 34 s
Overall bit rate                         : 1 655 kb/s
Encoded date                             : UTC 2023-04-14 15:04:49
Tagged date                              : UTC 2023-04-14 15:04:49

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main 10@L4@Main
HDR format                               : Dolby Vision, Version 1.0, dvhe.05.03, BL+RPU
Codec ID                                 : dvhe / dvhe
Codec ID/Info                            : High Efficiency Video Coding with Dolby Vision
Duration                                 : 59 min 34 s
Bit rate                                 : 1 652 kb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.033
Stream size                              : 704 MiB (100%)
Encoded date                             : UTC 2023-04-14 15:04:49
Tagged date                              : UTC 2023-04-14 15:04:49
Color range                              : Full
Codec configuration box                  : hvcC+dvcC

i have tried also the original MP4 videostream, without muxed audio. To be shure, there is no error in muxxing. Same result.

Playback with Plex plays only audio with black screen and with Infuse stuttering on Apple TV.

On Ipad Pro 2017 works fine.
On fireTV works fine.
On LG Oled and Plex works fine.

Any Ideas ?

7 posts were merged into an existing topic: Playback issue with 1080p HDR files (1st gen ATV4K)