Dolby Vision profile 8 too dark

When playing MKVs that are Dolby Vision profile 8 (Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU, HDR10 compatible / SMPTE ST 2086, HDR10 compatible), they appear too dark. Almost like there tint is turned down resulting in black crush and dim light areas. HDR-10, HDR-10+, and even DV profile 5 files all look good.

My current hardware setup is a 4K HDR Samsung TV that supports HDR-10/HDR-10+ directly connected to an Apple TV 4K 2021.

  • I have tried setting the Extended Dolby Vision setting in Infuse to Auto, Limited and Off and have the same result.
  • I have tried turning off/on Match Dynamic Range and Match Frame Rate in the Apple TV settings and have the same result.
  • I have tried setting the output to 4K SDR 60Hz with the match content settings on and off. With the output set to 4K SDR 60Hz and both match content settings turned off the image no longer looks too dark. Obviously, this is not ideal, because I would like to have HDR for other content.
  • I updated my TV’s firmware to the most current version, which made no difference.
  • Apple TVOS and Infuse are the most current version.
  • I have tried playing the files on my iPad Pro 3rd Gen, which supports DV with Extended Dolby Vision set to Auto in Infuse and it looks good. I’m not sure how to tell if this is playing back in DV or SDR on the iPad.

What I am trying to figure out is, what is the root of my problem. My understanding is, Dolby Vision profile 8 is supposed to support fall back to HDR-10, which has always looked fine on my TV. So, is this a hardware issue, settings issue, or an issue with the files? in all cases I’ve tested, the problem is with any DV file that is dvhe.08.06 and not dvhe.05.06.

Thanks in advance. Any help is appreciated.

Example of a DV profile 8 file in 4K HDR mode.

1 Like

Example of a DV profile 8 file in 4K SDR mode.

1 Like

If forcing SDR output appears correct, but HDR output appears too dark this is likely related to settings on the TV or perhaps an issue with the HDMI cable.

Even now in the year 2023, most TVs have an HDR mode that will need to be enabled for each HDMI input you plan to use HDR sources with. I found this video for Samsung which may help.

I thought I had checked that before, but just checked again to confirm. On my Samsung it had Input Signal Plus instead of HDMI UHD Color. It was enabled for the HDMI input. I tried turning it off and lost the signal. I turned it back on.

I checked the signal info for the HDMI input used on the TV and it shows as UHD HDR. I’ve also tested with the Check HDMI Connection option on the Apple TV.

I played around with picture settings again on the TV and with a 4K HDR 60Hz signal, the Dynamic Picture Mode looked pretty good for the DV profile 8 files, but other content looked a little blown out. I’ve always avoided that setting and thought it was just for showroom displays.

Hoping this helps. The Apple TV will only try to read from the Dolby Vision profile exclusively if you select “4k hdr”. Even if it should default to HDR10.

You must select 4K SDR 60 and also select Match Dynamic Range.

This will still display HDR signal on your Samsung TV. Just not read from the Dolby Vision profile which is what is causing the image to be dark and not right.

I promise. I spent hours researching this for my own setup similar to yours. Although you will set Apple menu to 4K SDR 60, it is still displaying HDR on the Samsung. It is the correct way to bypass DV issues.

Once you set it as I mention above you’ll notice by going to info on your Samsung. Watch something you know 100% is HDR and also something you know for certain is NOT HDR and you’ll see the profile of your Samsung changes each time as it should.

I hope this helps you my friend.

1 Like

Following up on this. I kind of gave up after a while, but was in the advanced settings of my TV recently. I turned off a setting I thought I tried before, Enhanced Contrast. So after setting my ATV to use match dynamic range, set the picture mode to Dynamic on the TV and turn off the Enhanced Contrast on the TV, I now am getting a good picture for DV/HDR and SDR content. Samsung has all of these “smart” features that are anything but. At this point I think I have nearly all turned off because they made things worse or were annoying.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.