Dolby Vision Profile 7 & 8 support (.ts/.mkv files)

I think it must be allowed to say that it would have been a disappointment without being compared to a cartoon character who is described on Wikipedia as “bringing disastrous misfortune to everyone around him”. Is that really what I did with that statement? I must admit I don’t quite see your point.

If it was just meant as a well-intentioned joke, then that’s fine, but if not, it was kind of inappropriate.

Yup, just admiring how diligent you’ve been working on this and didn’t want you to think you were Joe.

Hmmm, I think your joke was a little too deep for me, or maybe I just don’t get it because I’m not familiar with that cartoon character :slight_smile:

2 Likes

I must admit it was completely lost on me too.

If the original MKV has an aspect ratio of 16:9, so there are no black bars in it, like for example “The Shining”, and HandBrake therefore doesn’t crop either, I assume that “crop” can be set to either “YES” or “NO” because the result will be the same anyway?

Correct. They both would have the same end-result in theory.

Yes please add a force/use HDR option instead of DV.
At the moment I want no longer watch films or series that contain DV, as this causes some problems for me.

I agree with you that it is desirable to be able to choose a setting regarding DV in Infuse. I hope and believe that this will be implemented.

At the same time, if you generally don’t want to have video with DV, there exists simple-to-use tools that allow you to remove DV metadata from video so that you are left with HDR10. Let me know if you want more information about that.

Otherwise, one must not forget that DV can be deactivated in Apple TV’s own settings.

There is a video I have tested in Infuse (public version) that is a bit of a mystery to me.

Information about the video:

  • Jaws UHD blu-ray
  • Ripped with MakeMKV
  • RPU (not cropped) demuxed from MKV
  • MKV compressed with HandBrake (Crop automatic setting activated, did crop)
  • Uncropped RPU injected in HandBrake MKV
  • Muxed with MKVToolNix

The weird thing is that when I play the video in Infuse in tvOS, the colors turn green. However, when I play it in Infuse in iOS the colors are correct.

The error is probably not related to the compression in HandBrake, because the HDR 10 compatible output MKV from HandBrake plays with correct colors in both tvOS and iOS.

The uncompressed P7 version plays with correct colors both in tvOS and iOS. Same thing with an uncompressed P8.1 version I made.

The difference lies in the version that has the RPU file reinjected in the HandBrake output only.

Could it be that incorrect cropping of the RPU file results in wrong colors in tvOS, but not in iOS?

I tried different settings in Apple TV (match dynamic range on and off, Dolby Vison, HDR and SDR) with the same green colors as result.

I’m making another version now, with cropped RPU, to see if that makes a difference.

Mediainfo
Video
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5@Main
HDR format : Dolby Vision, Version 1.0, dvhe.08.06, BL+RPU, HDR10 compatible / SMPTE ST 2086, HDR10 compatible
Codec ID : V_MPEGH/ISO/HEVC
Duration : 2 h 3 min
Bit rate : 26.5 Mb/s
Width : 3 840 pixels
Height : 1 632 pixels
Display aspect ratio : 2.35:1
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.176
Stream size : 22.9 GiB (86%)
Writing library : x265 3.5+1-f0c1022b6:[Windows][GCC 10.2.0][64 bit] 10bit
Encoding settings : cpuid=1111039 / frame-threads=3 / numa-pools=12 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / input-csp=1 / input-res=3840x1632 / interlace=0 / total-frames=0 / level-idc=0 / high-tier=1 / uhd-bd=0 / ref=4 / no-allow-non-conformance / repeat-headers / annexb / no-aud / no-eob / no-eos / no-hrd / info / hash=0 / no-temporal-layers / open-gop / min-keyint=24 / keyint=240 / gop-lookahead=0 / bframes=4 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=25 / lookahead-slices=4 / scenecut=40 / no-hist-scenecut / radl=0 / no-splice / no-intra-refresh / ctu=64 / min-cu-size=8 / no-rect / no-amp / max-tu-size=32 / tu-inter-depth=1 / tu-intra-depth=1 / limit-tu=0 / rdoq-level=1 / dynamic-rd=0.00 / no-ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / no-strong-intra-smoothing / max-merge=3 / limit-refs=3 / limit-modes / me=3 / subme=3 / merange=57 / temporal-mvp / no-frame-dup / no-hme / weightp / no-weightb / no-analyze-src-pics / deblock=0:0 / sao / no-sao-non-deblock / rd=4 / selective-sao=4 / no-early-skip / rskip / rskip-edge-threshold=0.050000 / no-fast-intra / no-tskip-fast / no-cu-lossless / no-b-intra / no-splitrd-skip / rdpenalty=0 / psy-rd=0.75 / psy-rdoq=4.00 / no-rd-refine / no-lossless / cbqpoffs=0 / crqpoffs=0 / rc=crf / crf=20.0 / qcomp=0.60 / qpstep=4 / stats-write=0 / stats-read=0 / ipratio=1.40 / pbratio=1.30 / aq-mode=1 / aq-strength=1.00 / cutree / zone-count=0 / no-strict-cbr / qg-size=32 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=1 / overscan=0 / videoformat=5 / range=0 / colorprim=9 / transfer=16 / colormatrix=9 / chromaloc=1 / chromaloc-top=2 / chromaloc-bottom=2 / display-window=0 / master-display=G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(40000000,50) / cll=1000,259 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / no-sbrc / hdr10 / hdr10-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=0 / analysis-save-reuse-level=0 / analysis-load-reuse-level=0 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=1 / refine-ctu-distortion=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-analysis-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei / no-hevc-aq / no-svt / no-field / qp-adaptation-range=1.00 / scenecut-aware-qp=0conformance-window-offsets / right=0 / bottom=0 / decoder-max-rate=0 / no-vbv-live-multi-pass / no-mcstf
Default : Yes
Forced : No
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
Maximum Content Light Level : 1000 cd/m2
Maximum Frame-Average Light Level : 259 cd/m2

New beta available today (7.5 - 4357) with more fixes.

  • Added HDR option to Dolby Vision setting
  • Fixed Dolby Vision playback for some P8/HLG videos

Still working on handling of CM v2.9/4.0 metadata. :crossed_fingers:

2 Likes

Sorry I am a bit lost with the massive amounts of comments I cant seem to find an answer, does the apple TV 4k 1 gen support “real” DV when playing back DV profile 7 and 8 or profile 5 when on mkv? because when I play files which are DV profile 8 the DV logo pops up on my TV but I understand that that might not actually be DV but just HDR10.

At the moment only profile 5 will play correctly. Profile 7 falls back to hdr 10, and for some people profile 8 does as well.

Like you on my setup profile 8 is incorrectly putting my tv into Dolby vision mode when it’s suppose to fall back to hdr 10.

For DV profile 5 to play correctly does it need to be mp4 or can it be MKV?

1 Like

MKV is fine

1 Like

The proper settings on the ATV if you want HDR and not Dolby Vision, are: 1st - do not “enable Dolby Vision”. Set your ATV to either 4K SDR or 4K HDR. Turn on “Match Range”.

SDR content will play in SDR. All HDR content, including Dolby Vision, will play in HDR10.

That isn’t true in my experience.

Putting the ATV in SDR/HDR/DV mode just applies to the ATV UI and apps that don’t properly support the Match Range option (Peacock, and at one time Hulu, but I think Hulu was fixed).

For apps that do support Match Range (Infuse, Plex, ATV, Netflix, Paramount+, Disney+, HBO Max, etc), it doesn’t matter what you have the UI set to. If the ATV detects your display supports HDR or DV and you enable the Match Range option, the ATV will switch accordingly to HDR or DV, depending on the content.

Setting your ATV to 4K SDR and enabling Match Range is the recommended way to set your ATV in AVSforum, etc, for max compatibility and avoiding burn-in. You only have to manually enable HDR and DV then for the smaller set of apps that don’t properly respect the Match Range option.

1 Like

That is correct.

Video would be perceptually identical with the FEL dropped unless something goes wrong on the studio side and some stuff that should be in the BL ends up in the FEL. Rare but there are discs where this has occurred.

This will be available to you (at least in Infuse) in the upcoming 7.5 release.

In this upcoming release you will be able to choose how to handle P8 Dolby Vision videos. You can either play them as Dolby Vision or have Infuse play the underlying HDR10 layer and enable HDR output.

1 Like

That sounds great! Do we know yet if it works correctly going from 8.1 to 5? I know that profile 5 has a custom color space…