Dolby Vision Profile 7 & 8 support (.ts/.mkv files)

@bigbadrabbit there are other criteria like Dolby Vision Versions - CMv2.9 vs. CMv4.0. CM4 is not supported at the moment. But I asked a similar question and no one seems to know all the other reasons. I used the DV7 to DV8 script posted here and it only appears to work on some files.


Thanks for the help. Unfortunately none of the tips helped.

Set Infuse to AUTO and used the “DV7 to DV8” tool on that file but it’s still playing the HDR fallback. Guess I’ll have to wait then.

1 Like

With the tvOS17 release today is there a corresponding Infuse update on the horizon? Hopefully some of these DV issues are resolved.

You can see what’s on the near release agenda here.

Hi guys,

just a technical questions. Since tvOS was only able to play Dolby Vision 5, Infuse integrated a feature that would convert Dolby Vision 8 to 5 on-the-fly.
However tvOS 17 now supports Dolby Vision 8, will such files still get converted with infuse?

I’m guessing that will be part of what they look at with the upcoming release that deals with tvOS 17 and how it handles things. You can keep an eye on the Infuse releases here and note for now that 7.6.2 addresses tvOS 17.

1 Like

I have run into a couple recent StudioCanal releases that are FEL and I have converted them to Profile 8 for playback in Infuse, but they only play in HDR10. I have checked the mediainfo for both titles and there is nothing out of the ordinary. Cutthroat Island and U-571 are the first titles (I know of anyways) that I have been unable to play in DV despite being DV. Anyone else have these and have them playing properly in Infuse?

On a sidenote, they do play DV when I turn on Dolby Vision in the AppleTV settings. Generally, matching content has worked fine in the past for enabling HDR10/DV mode on my TV. Those two titles are not forcing the switch. I am on tvOS 17 and running the latest beta as of today.

Were they converted using one of the scripts posted here on the forum (or another method?)
When you browse in Infuse does the file show the DV badge?
If yes to both you’re probably best to just wait and see what happens when Infuse introduces its native Apple profile 8 support.

For what it’s worth I just grabbed two different profile 8 copies of Cuthroat Island and both only play as HDR. (Both used as is rather than any conversion scripts posted here on the forum)
So again it’s probably time to see what happens with native profile 8 support.

1 Like

Just to rule out some variable (Infuse and its DV processing), what happens with ATV os17 internal player, I.e. when you share that video from a Mac and use ATV->Computer to view that movie? Is that what you meant by “they play in DoVi when you have match content…”

I think the presence of cmv4 could force fallback to HDR10, the script(s) shared in this thread do remove cmv4 in P7 to P8 processing.



1 Like

Great call everyone! I used Speedy’s script to do the conversion (instead of the Reset_9999) and Cutthroat Island now plays in DV in Infuse. Looks like the CMV4 callout was most likely it. Thank you all for the assistance!


oh so you’re thinking the appropriate workflow of RESET9999 does not remove cmv4? Hmm

It does not appear to be or there is something else at play. Fact is both movies I was having problems with I converted with Speedy’s script and they play without issue now.

Do you have a link for the script ?


Hey folks, I put together a docker container a little while after the 7.5 release to convert my media with fileflows and stupidly didn’t check here to see if somebody had actually already written a script for this :sweat_smile:

I’m not super confident on the various conversion/muxing tools but I’ve raised a PR here to align my docker entrypoint script to @speedy’s fine work, if anyone has the expertise I’d appreciate any feedback

You can test the container using something like

docker run --rm -v /mymediadir/mytestmoviefolder/:/opt/media mymoviefile.mkv dvhe.07

This ^ command would mount a directory into the containers working directory, the first argument is the file you want to target from the mounted directory and the second argument is the profile type you expect the file to have. The script will do all the necessary bits to convert/remux the file to profile 8. If the file doesn’t contain the profile you provided in the second argument then the container will simply exit and leave the file untouched

1 Like

Speedy’s script evidently “repairs” Profile 8 as well. I know he had stated that previously, but I can confirm that one of the titles I had converted with Reset’s script now plays correctly after running it through Speedy’s. Which is awesome as now I don’t have to re-rip my very large collection. Thank you @speedy for the great script.


If you want to use Reset_9999 Script you have to use workflow 2-1-5 if I’m remembering correctly to remove CMv4. His script try’s to preserve everything when converted to profile 8. But since Apple TV can’t play Profile 8 CMv4 correctly yet. You have to use the Fix/Repair section to remove it. Hope this helps with using his script.

1 Like

Thanks @Iam2smart. I knew it was possible, but I hadn’t poked around in it extensively. I wish I could set it to do it in one step. Really, I just wish Apple would correct their content mapping support.

No Problem. Hopefully with tvOS 17 and when infuse updates support we won’t have to worry about CMv2.9 or CMv4 anymore.