Dolby Vision/Atmos banners re-appearing (or dropping to HDR) after seeking


I have an AppleTV 4K '22 latest version and am using Infuse Pro 7.5.1

When watching Dolby Vision files, every time I seek to a different time, or even 10 seconds rewind or forward, my Tv (LG G3) is displaying “Dolby Vision” and “Dolby Atmos” banners, again and again. It only doesn’t do it when you pause and play without seeking.

I’ve tried DV content on AppleTV+, Amazon Prime and Netflix apps and all of them are normal. I also tried the Plex app on ATv on the same media, playing Dolby Vision, and it’s also fine. The banners only appear once when you select and start playing the video and it doesn’t re-appear when you seek within the file.

This happens on all DV files.

Could you please check if this is bug? If not could you please let me know if there’s any way I can stop this from happening as it’s very annoying.


We have a change coming in 7.5.2 for a similar issue, so it’s possible this may help with what you are seeing.

7.5.2 should be available on the App Store within the next few days.

1 Like

Thanks James! Looking forward to it. Will upgrade, test and report back.

1 Like

@james Hello again. Just to report that I upgraded to the latest 7.5.2 version and the behaviour unfortunately persists. How may I help you diagnose what’s causing it?

Would you be able to replicate this issue, and send in a report from your device (and post the 5 digit code here)?

Also, if you’re able to send in a video file you are seeing this issue with that could also be helpful in tracking down what may be going on here.

Sure. Just replicated it and submitted the diagnostics.
The code is YRJEN.

I’ll shortly send a video of the actual behaviour you’ll see in the diagnostics.

Here is the video of the behaviour on 7.5.2 vs Plex on Apple Tv on the same file.

Infuse Pro 7.5.2:


On the Infuse Pro, I loaded up the file, you’ll see the Dolby Vision and Dolby Atmos banners appearing on the upper right side corner. From that point, as soon as I stop and seek to another point in the file, and press play, you’ll see that the banners are reappearing. Only time this doesn’t happen is if I stop, and play again from the same point.

On the Plex, the banner appears once when the file is first started to play. Same stop - seek- play behaviour does not make the banner appear again.

This happens in any file that plays on Infuse Pro with Dolby Vision or Dolby Atmos.

I read somewhere that this might be related to app losing its “bitstream” when seeking but not sure how reliable this information is tbh.

I’m also wondering if this is specific to the new LG G3 series and the firmware its running. Granted I’m an early adopter so we’ll see if other people experience this as they start buying this new model.

Hope this helps! Please let me know if there’s anything else I can do. That specific video file is quite large (10gb) so let me know if you still need it, happy to upload.


1 Like

Thanks. Will be looking into this.

1 Like

Thanks James! One additional finding. I just realised that if a DV file does not have DolbyAtmos sound, it looks like the banners behave as they should. Only when a file has DolbyVision and DolbyAtmos sound at the same time, then the banner issue seems to be appearing. This may help you get to the bottom of this.

Also weirdly, app just asked me to unlock DolbyAtmos for free (Included w/ Pro?)two times in the same app session. This never happened before. :thinking:

Are you sure one wasn’t for DTS?

This will explain.

1 Like

Ah I see, thanks for the explanation. I think it asked for the same format twice but maybe it was different. I’ll check closely if it does it again.

1 Like

Hey @james , thanks for your time looking into this.

I saw that this issue was included into the upcoming 7.5.3’s list of fixes but then it got dropped. Just wanted to check if this one is being postponed to a later realease or will be a “will not fix” / “working as intended”?


Since this thread is still tagged as ‘in-progress’ it appears it’s just moved back and probably will show up soon.

1 Like

Hi, I’m having a problem with a particular movie (the flash) If the movie starts from the beginning it takes the dolby vision correctly, but if I exit the application and playback the movie again it takes the movie in hdr (there is no way to play Dolby vision again unless I put it back from the beginning)

Plex client works fine, it’s a direct play and switch correctly dv, but in infuse app fail to switch dv and play hdr

well, apparently it doesn’t take dv when the format is mp4. something that is very annoying is that when you go back, forward or change the chapter, the dolby vision logo is jumping all the time, why is this? Is there a way to disable it?

This is an issue with certain samples we are aware of and have been looking into.

Since Apple announced native support for DoVi Profile 8 in tvOS 17, we’ll first be working to implement changes to take advantage of these new features and then evaluate any remaining issues afterwards.

With regard to other apps, there is a 99% chance they are simply playing these files in HDR and then forcing the Apple TV to switch to Dolby Vision mode, which many refer to as ‘Fake Dolby Vision’.


Awesome news. I did wonder what the plan was going forward.

To be clear unless that Dolby vision is Profile 5 then Plex is giving you fake DV as @james mentions in the reply above.

so it is something that will be resolved in the new ios update. thank you