Do I need to upgrade?

I have an ATV 2 with 4.4.4 firmware that was jailbroken over a year ago.I have never saved any blobs as I just heard about them.

I'm not sure when signatures occur, so is it too late to save my blobs?

Also, is there any need for me to upgrade to say 5.3 or am I too late for that?

thanks for any help.

Not too late to save your 4.4.4 signatures. I believe 5.3 can still be jailbroken. As long as you saved you old signatures you can always go back.