do i need to buy a new atv 2?...rapid light and usb hookup symbol on scrn

I ran seas0n pass and it said that it was successful and that i could disconnect the usb. Then I immediately went to hook it up to my tv and all i got was a usb hook up picture like it was currently in usb mode or something. In addition the light is simply rapibly flashing. I dont know what is wrong, and I think my Apple Tv2 is fried.  As I have attempted to do the whole process over multiple times and it is still doing the same thing. If anyone has any rescue tips to get this thing working properly I would appreciate it.

I'm seeing this too. Seas0npass tethered boot screen indicated success, but after removing usb and connecting HDMI it showed Itunes logo with usb cord image... indicating I need to connect the ATV2 to iTunes.

Another update to Seas0npass coming soon?

 

 

Yep, I'm getting the same thing. This is what I'm doing:

- Open Seas0nPass
- Click 'Tethered Boot'
- Connect USB to ATV, connect power cable
- Hold Menu/Play for 7 seconds to put into DFU mode
- Seas0nPass does it's thing and says 'USB is safe to disconnect'
- I yank the USB cable out, put the HDMI cable in, but then it comes up with the 'Connect to iTunes' logo on the TV and the light on the front keeps blinking, even if I soft-reset it.

Its fine, you just have to restore it back to the original firmware using iTunes. You might have to do the alternate DFU mode process for it to work properly though. See: http://forum.firecore.com/topic/3857

 

Then, follow those same alternate instructions to do the jailbreak. The jailbreak only works from a working and booting ATV.

I have exactly the same problem ...

Managed to do everything successfully, except the tethered boot thing ... what a pain in the a$$

When it's finished the tethered boot and says I can unpug the USB, I do that and immediately plug in the HDMI cable, only to be greeted by the USB plug showing a connect to iTunes graphic.... :(

Having already bought the ATVflash (black) product for two years, any ideas what I can do next?

Thanks for any help ... :)

Regards,

Doug

What does Firecore have to say about this?  I and so many other people seem to have exactly the same problem!

This happened to me too, I had to restore the atv and start over again. If you can't finish the restore, which happened to me, see if there is an upgrade to iTunes available (this fixed it for me) or try restoring on another computer.

What I realized is that I had clicked over to the browser while running the ATV Flash process the first time, it's a script so you need to just click "GO" (or whatever it is) and more or less walk away, don't touch iTunes and don't interupt the script until it's done working.

So if you have the itunes logo and usb thte only thing you can do is restore and start over?  I just want to be sure that I shouldn't keep trying to redo the tethered boot.

 

 

I just recently tried to jailbreak my apple tv2 again after the season pass 6.9, and having same problem. Amazing how i have tried 3 different versions of season pass and not one of them has yet to work for me. Anyway, now when I try and restore my apple back to the factory restore, I am getting an error message saying that it cannot do a restore due to error (9). I dont know what to do now! Some one help?

I'm having the same problem.  After JB and tethered boot, I plug i the HDMI cable and the screen only shows the iTunes graphic and USB cable....nothing else happening...luckily you can disconnect from this and run the restore...it states an error during the restore but after hooking it all back up, the ATV2 goes back to a factory setting.

 

I've tried the JB twice now with no joy...any one have another JB tool besides Firecore?  I really want to get 1080p running along with XBMC to start streaming my movies.

 

thanks

If you're seeing this issue please try re-jailbreaking with the latest 0.6.9 (36). You can check the version through the 'About' menu in Seas0nPass.

After this if you're still having trouble please submit your debug log as described here: 

http://forum.firecore.com/topic/3759