Disabiling Updates

Beginning last night my Apple TV2 started rebooting after watching about 10 minutes or so of video on XBMC (I jailbroke it with Seas0nPass and am running XBMC - nothing else added).  From doing a bit of research, I gather that it has something to do with Apple TV2 connecting to the Apple servers for the update to iOS 4.3.4 and that I need to disable the updating.  I’ve already turned off the automatic updating within the Apple TV2’s menu, but is there something else I’m missing?   Is there some other update setting that I need to turn off that I’m missing?  Thanks!   Really looking forward to a jailbrake for iOS 4.3.4 - I’m getting tired of seeing the “Update available” window and clicking to not update at this time.

 

John

  1. Based on your description that you are seeing the Update window I fear you have not actually turned off Automatic Updates, as you would not see this window. 

 

  1. I also know that Apple is still communicating with the aTV2 even with Auto Updates turned off since my aTV2 no longer allows rentals until I update the device.  

Thanks for the quick reply!  Is this the Automatic Updates under the Apple TV menu?  Or is there another setting that I need to find and turn off?

Have you disabled it udner the FireCore Maintenace menu?   The Apple supplied setting simply disables applying autmatic updates - it does not disable telling you about them.

I have also installed UpdateBeGone via NitoTV, but I am not sure if that is required if you have set the FireCore option.  I had it set before the FireCore option became available.

Didn’t think about the FireCore menu (probably because after I installed it, I set it so that it doesn’t show up in the menu - now to just figure out how to restore it to the menu!  Anyone point me in the direction of info on how to do that?).  I just read about the NitoTV option.

He meant the Maintenance menu that shows up after you install aTV Flash.  If you have that then there is a setting in the Maintenance menu to shut off updates which will fix your problem.  

If you have not installed aTV Flash (which you should, its worth the money) then you have to push a file via ssh to the aTV to stop auto updates or else they will continue to crash your system.  Do some googling in the XBMC forums about this issue and you will find your answer.

What he said.

UpdateBeGone installed via NitoTV will do this.  That is the way I did it before I bought ATV Flash. I must admit since the question was posed in the FireCore forum I assumed the user had installed ATV Flash.

Sorry guys.  Didn’t realize that it was posted in the wrong forum.  But I’ll have to get aTV Flash.  You guys have been great help!